Jump to content
ericsiewkk

Suzuki swift M16A VVT issue

Recommended Posts

i have a problem with erratic vvt position when vvt is activated causing the car to jerk as the cam actually changes position randomly.

engine is suzuki swift sport m16a vvt running with trigger mode "Suzuki Swift V2 VTC"

attached is the log file

suzuki vtc.llg

Share this post


Link to post
Share on other sites

The cam is not moving in your log but the Inlet LH error counter is incrementing quickly.

Have you done the cam angle test to confirm the trig 2 VVT offset is set correctly?  Procedure below.  Use a test pulse count of 6.

w2mycj.png

Share this post


Link to post
Share on other sites

Yes, I did have a quick look.  When testing I had something odd going on that I couldnt understand either.  I had to set my trigger offset 360 different to yours to get the same cam angle test results, then my cam control was erratic like yours.  With my trigger offset set to 0 my VVT worked properly.  So Im not sure if that means the vvt mode is set up wrong or maybe some of these engines have teeth in different locations.  I havent had a chance to discuss with our engineering guys yet.

Can you try this map below, I have set up the user defined VVT mode.  It will only give 35deg max advance but if it works for you it will give me some good info to pass back to engineering to check where the problem is. 

User defined.pclr

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...