Jump to content

Chrismac

Members
  • Content Count

    5
  • Joined

  • Last visited

About Chrismac

  • Rank
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Thanks for the info. I though the r35 coils were different wiring than the neo coil packs
  2. I kinda had the same issue back when I First started tuning my rb25 neo. Turned out it had to do with a (too aggressive) timing map. The ecu was trying to pull to much Timing to quickly once it came into boost.can u post a pic of ur timing map?
  3. Hello. Hoping someone can shine alittle light on my issue. The car is a 99r34 skyline gtt with the Rb25det neo. I’m running the link g4+ ecu. The car last year was running 18psi boost and ran great And now this year I uped the boost to 25 psi and it started have bad misfire above 5500 rpm. Fuel pressure is at base 50 psi on a 650cc injector at around the 90% duty cycle so I’ll be upgrading those but as for the issue I’m having ,something doesn’t look right with the dwell timing. The coil packs are new oem from Nissan last year and I don’t see any issues on the coil boots but the dwell tim
  4. OK thanks.there r still a few things im new at when it comes to this ecu lol .ya its ballpark for now as i couldnt figure out y i had no knock signal so i couldnt set it up.
  5. hello new to the form here.just have a uestion about setting up oem knock control.i installed 2 new oem rb25det neo knock sensors and cant seem to get them to read any data.im sure it has to do with setting but i just cant seem to get them working right.any chance you could have a look at my map ? any input would be great. current oct 14.pclr
×
×
  • Create New...