Jump to content

g4/v88 to racepak


Recommended Posts

Is there any chance that someone may be kind and generous enough to help me with some guidance on how to get some data to display on a racepak IQ3 non logger from a post 10000 ser no G4/V88 (actually v88 but i was told they are the same as G4). To be honest i dont really understand the settings on either software and i find the Racepak datalink especially confusing. I have a module from Racepak that says for G4+ and i have been told that this is correct, i also have a Vipec module but had no success with that either. I must have wasted days on this so far and i'm nearly ready to throw the Racepak away.

Thanks in advance

Link to comment
Share on other sites

Hi Leon 

The G4+ module is geared to work on CAN from the ECU, The Vi-pec module was serial based. 

Using the G4+ adapter you would follow the following steps on the ECU

Go to ECU controls > CAN Configuration

Select 1 MBPS for the data rate

select ECU Transmit 

Load the Generic Dash.lcc file 

Set transmit rate to 50Hz

Apply and then Store 


Link to comment
Share on other sites

Hi Simon

Thanks for that, i have set as suggested, i the transmit format available as well and have set that to sequential.

Now that i look at it the module i have is 230-VM-EFILINKC SN:501520 LINK G4 CAN INTERFACE

No luck yet

Link to comment
Share on other sites

19 minutes ago, leon36 said:

i the transmit format available as well and have set that to sequential.

That setting should be greyed out just like Simons picture above if the correct stream was loaded.  Can you attach a copy of your map (.pcl) so I can take a look.

Also have you done the "read Vnet config" thing in datalink?

Link to comment
Share on other sites

H Adam

Had a guy around today that thought he could fix it, still not working. we have done read vnet thing still no data.

Im happy to just use the vipec cable at this stage as it is currently installed. I have heard stories of cutting wires inside the control unit to make something work so today i slid the board out to check and no wires have been cut or removed.

ill have a go at attaching my file now.


I cant be 100% sure that the link cable is functional as it has been modified at some stage as there is a dtm 2pin connector inline.

Link to comment
Share on other sites

The CAN set up was a bit wrong but the serial set up is ok.  I have fixed the CAN setting.  So either of your Vnet devices should work now.

Note for the serial to work you cant have a laptop/VTS connected to the ECU and you must power cycle the ECU with the Vnet module connected/no laptop connected.  Then do the Read Vnet config again.

bmw83e85 CAN Fixed.pcl

Link to comment
Share on other sites

Thanks Adam,

uploaded that map to my ecu.

Now when I try to read vnet my computer blue screens. Tried 3 laptops all the same. no idea now.

Thanks for your help anyway

(security kernel failure) no idea what that means wiil have to find an it wizz now

Link to comment
Share on other sites

So if you do the "read Vnet config", do all the ECU channels/buttons show up?  Its been a long time since I touched a IQ3 but im pretty sure it should find all those channels regardless of whether the ecu is connected/sending data or not.  It is basically just reading the config from the adapter.  

Link to comment
Share on other sites

Yes, i get all the channels, just no actual info. i can change the information or parameter that is displayed, but everything is just 0.

If that makes sense.

I can have the engine running and see oil pressure on VTS, however the dash display is 0 with both cables/modules even when strictly following your instructions for the vipec module.

I have personally seen this control unit display info on a motec dash so i am sure the vipec is outputting info. Im almost positive this is operator error so i really appreciate your assistance.

Link to comment
Share on other sites

Hi Adam,

Managed to get them to talk to each other.

Used the link cable. After cutting it open I found different wires in number and colour on either end. After a fair bit of measuring I located the can h/l (which were opposite to the help file) connected them up, reread vnet and now I have data. Now to start what looks like a long and laborious task of configuring each channel.

One of the new link dash's is still on the agenda.

Thankyou very much for your assistance with this, I will be nominating you for a nobel prize.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...