Jump to content

G4X & Mazda GTX 1995

Mazda GTX

Recommended Posts


 Car won't start on G4X (on stock ECU starts instantly, flawless),

Fuel pump, injectors 1&2 work, spark works.

When cranking it gives a trigger error (I have tried bunch of trigger settings none where able to start engine) -Distributor faulty.

no TPS connected ( I have 4 wire TPS (my older GT have 3 wire sensor), where unable to find connected input for ECU) -TPS faulty.


Link to comment
Share on other sites

TP sensor:

LG/W is the signal, this should go to ECU pin 7.

BR/B is ground.

LG/R is 5V, this should go to ECU pin 8.

R/W is not needed for the Link ECU.

So first check you have 5V when measured between BR/B & LG/R.  Then confirm you have a voltage that varies with TP movement coming out of the LG/W wire.




Link to comment
Share on other sites

TPS Sensor is faulty, Thank You for pin-out.

Still car should start without it, so far I get only gasoline smell from it, no spark.

If both triggers are set to hall/optical, 

1.(trigger 2 pull-up is on.)

2. (trigger 2 pull-up off.) I get some gasoline smell and one single spark.


Link to comment
Share on other sites

No those spikes are just a ground offset from the starter motor kick back or something.

You have no trigger 2 signal, either the CAS is faulty or the wiring between the CAS and ECU is broken.  

CAS pinout below.  You can check the CAS is ok by pulling it out and backprobing the trigger 2 pin with a paperclip or similar then watch the voltage while turning it by hand. It should jump between 0 & 5V a couple of times per rev.

If that looks ok then you can do the same test at the ECU pin 10 to check the signal makes it to the ecu.


Link to comment
Share on other sites

have you calibrated the timing?

Triggers -> Calibrate -> Set Base Timing

crank engine with a timing light attached and adjust the offset value until the angle measured with the timing light matches the angle the ignition is locked to.

Also might be worth increasing the master fuel number a little if it still doesn't start once you've calibrated the ignition.

Link to comment
Share on other sites

Can you try to give us a photo of the CAS wheel inside the distributor (i dont even know if it is visible), the trigger pattern in your triggerscope above doesnt match the normal MX5 NA/BP pattern.  These normally have 4 trig 1 teeth for every 2 trig 2 teeth, but yours seems to have 4 trig 1 teeth for every 1 trig 2 teeth.  Normal BP pattern is shown on the bottom of the pic below where it says "NA".  Is it possible someone has cut one of the trigger 2 teeth off your CAS?  I think we should still be able to make it work, I just want to confirm how many teeth you have on each wheel before making a suggestion.


Link to comment
Share on other sites

Can you attach the actual log and the tune.  If there are sparks at the coil lead but not coming out of the distributor then that would suggest the rotor is not pointing at a post when a spark occurs - try shifting the trigger offset by about 45 degs at a time to see if you get a spark. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...