Jump to content

Idle Issues


Recommended Posts

Hi All,

Having really weird idle issues:

1) when idling the car seems to bog down sounding likes its going to cut out however after a drive or so it sometimes is fine.

2) idle often gets stuck around 1500 - 2000 RPM, once driving again it will stop perhaps on next idle.

3) when coming to a stop while driving (not all times) car will turn off when downshifting, i can see the vaultage dropping from the battery on my dash but often times while down shifting the car will cut out then once in next gear it will start it back up again?

Im not a professional tuner but im slowly getting and understanding.

I have attached the map if required.

Volvo Map.pclr

Ah i also forgot to mention, when startup on cold it is virtually impossible to drive the car smoothly for the first 1st min or so after letting it warm up a bit but the car is just so jolty :/

Link to post
Share on other sites

The E-throttle target and idle base position dont look quite right, generally you need most of the idle throttle to come from the main table , then the idle base position table is mostly just for the extra air you need during warmup. 

The 150RPM idle deadband is a bit extreme, usually 40RPM works well for DBW.

You've got no e-throttle relay assigned so that is why you are stuck running in set-up mode - be aware you have no safeties running like this.

You dont have any idle ignition control which isnt going to help things.

I suggest you update to the latest firmware too.

If you attach a log of some of these problems I can help with some changes.  

 

 

Link to post
Share on other sites

Hi Adam, thanks for the response ill get the firmware updated and try and get these logs.

I believe for the ethrottle there should be two wires incase there was a failure in one but unfortunately my car only has one at present, not sure if this info helps at all.

Link to post
Share on other sites

Hi Adam,

Managed to Log a couple of the issues, please see the attached files:

Cold Start file should show why the car is so bloody jumpy and un-driveable, but typical that it wasn't as bad today as it normally is.

Engine Stall simulates the weird idle i get but i had to rev the engine to get it to dip when the revs were coming down, just sounds like its going to stall after a rev or sometimes on idle like the revs dip too low or something.

 

Regards

Chris

 

 

Cold start.llg Engine stall.llg

Link to post
Share on other sites

I'd start with fixing your knock. 

Seems like its pulling timing left and right. (even when you just rev it)

Your DBW is in setup mode.. so not sure if you aware of that.

Your IAT might be interfering as its adding fuel pretty much all the time.

Raise your Overrun De-activation RPM in the range of oprating temp.. from 1500 say to 1800 see if that help with the dips.

Last but not least.. I'd enable Idle ignition. That should help with rpms dropping as well. 

 

Hope this helps.

Link to post
Share on other sites

Thanks for your reply!

Ok you will have to excuse the lack of knowledge, but what is wrong with the knock?

DBW, I did know that im not quite sure why but does this happen to do with there being no backup signal wire currently only have one signal input?

 

Ok ill raise the overrun as you have mentioned.

 

Is idle ignition as simple as just enabling it?

 

Regards

 

Chris

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...