Jump to content

Link G4X NGTR Unknown Errors and re-locking itself


Recommended Posts

Howdy, as you can tell from the title I have run into some issues that I can't seem to find online, and a particularly worrisome one that shut the car off and re-locked the ECU. This is a long winded one so sorry for the long read. Unfortunately I wasn't able to save the log due to the PCLink itself faulting and needing a restart.

First error, which I noticed upon first connecting to the ECU but hadn't seen since clearing it:
Error Code 9: Settings Underflow

It's not in the documentation anywhere, online or offline. So I wouldn't mind getting some info on that one.

The second issue a lot was going on, the car shutting down and ecu relocking, a handful of errors showing up, here is the timeline:
* Started logging, went up through gears 1-4, staying under 3k rpm, running rich but everything was working
* Made some changes to the fuel map according to the Mixture Map automatic updates
* Started logging again, got to maybe 2-3k rpm, car shut off
* A program error dialog popped up saying ISC Solenoid error (I think, it disappeared too quickly for me to take a picture)
* Program dialog popped up saying ECU is locked, contact dealer to unlock etc. (Maybe a red herring?)
* Tried cranking, and it cranked but didn't start
* Unlocked ECU again, cranked but didn't start
* Error Code 9: Settings Underflow appeared again
* Can't find it online, but a Fault Code for Injector Max Duty Reached
* Upon trying to open a saved known working tune, I got a program error dialog about invalid memory addressing or something along those lines, again the dialog disappeared before I could record it (would be good if these stuck around or were otherwise logged, even when not logging engine data)
* Turn everything off, re-connect, load known good tune (base GTST tune from Link, with initial configurations completed, master fuel set, nothing else changed), cranks and starts perfectly fine.

Is it possible the ECU did not actually relock itself but the dialog error was thrown improperly? I'm not so worried about the tune, it's the unknown errors and possible re-locking I'm concerned about.

I think the issue with starting was because I made changes too low in the RPM range from the automatic mixture map updates and those updates were inaccurate, I forgot to double check them.

PCLink version: 6.16.64
DLL Version: 6.16.64
DB Version: 6.0.101
ECU Version: 6.15.17
BootCode Version: 6.15.17
Main Board Rev: 2.4

Car and hardware Info:
1997 R33 GTST, RB25DET
Link IAT1-8 wired to Temp3 via expansion loom
Innovate SCG-1for Lambda, wired to AN Volt 2 via expansion loom
Internal MAP sensor plumbed into a T between the manifold and fuel pressure regulator

Cheers in advance for any info that can be provided!

Edit: Just noticed in another thread, Fault Code 9: Settings Underflow was addressed in a firmware update. It would be nice to know what it is and what issues it could cause still.


Link to comment
Share on other sites

5 minutes ago, Ehnto said:

First error, which I noticed upon first connecting to the ECU but hadn't seen since clearing it:
Error Code 9: Settings Underflow

It's not in the documentation anywhere, online or offline. So I wouldn't mind getting some info on that one.

I had the same issue. Update the firmware of the ECU, that should solve it.

Link to comment
Share on other sites

The settings overflow/underflow will be solved with a firmware update - basically it is just a scary warning that there is a setting out of bounds, it wont effect the way it runs.  

The re-lock thing sounds more worrisome, like some serious interference or something.  Does it have resistor sparkplugs fitted?

Link to comment
Share on other sites

It's using NGK BCPR6ES plugs which look to be resistor type plugs. The ECU is packaged up in the stock R33 ECU metal housing as you'd expect, not sure if that's enough shielding or not.

Good to know those settings fault codes won't affect the way it runs too, thanks for clearing that up!

Link to comment
Share on other sites

Tried a quick drive again today with updated firmware to see if it happened again, unfortunately PCLink froze one minute into logging, key off didn't work, only when I unplugged the USB cable did it start responding again. It was able to save the log after it started responding again though. The car didn't shut off, which is nice, nor did the ECU get locked. But, part of me wonders if PCLink freezing didn't prevent PCLink from causing the failure from last time?

Settings underflow stuff didn't show up, as expected from the firmware update, but still trying to get some solid footing so I feel comfortable driving and logging the car. First attempt had me stranded with a sudden shut down and re-locked ECU, and second attempt has had PCLink freeze and netted me no driving info. Hoping maybe you guys can pull some answers from the log attached.

In case it's important, the laptop is an ASUS F550L on Win10, 4gb of RAM and an Intel Core i5 4200, 1.6ghz.

Update: I decided to log via the internal ECU logging instead, everything worked perfectly fine and I could pull the logs off the ECU, happily recorded 2 x 20 minute logs, so I'm going to do that for logging. Are there any issues to logging all the time? Premature wear or anything like that?

I have also turned the volume on the laptop on, and noticed that the USB connection is dropping after 10 minutes or so, and will be spotty after that. I'm willing to bet it's the laptop, so I'm also going to chalk the previous errors up to that and I'll start a new thread if the re-locking happens again.

Log 2020-06-19 7;30;17 pm.llgx

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...