Jump to content

Link G4+ Fury acting up

Joe Bucci

Recommended Posts

I have a Link G4+ Fury on a 4G63 in a 1992 Mitsubishi Eclipse FWD Auto. I'm running a Kiggly Racing 12 tooth crank trigger and an OEM optical cam angle sensor with on of the "Slots" covered up to create one "Home" tooth. A common configuration on this engine.

I've had the car running good for a couple months now. It's been to the Dyno. It's been to the drag strip twice. It's been 10.7 @ 131mph on a stock appearing turbo with a terrible 60', so it's running well.

The 60' times have suffered because of the stock converter. Last week, I had the converter restalled. After it was back together, I fired it up and loaded it in my trailer. Went to the track and unloaded the car from the trailer. Was running completely fine. I decided to test the converter, so I stepped on the brake and floored it. The rpm came up to the 3200 rpm launch limiter much faster, less than 2 seconds, as it should, but it immediately lost momentum when it hit the cut and began climbing back up again. It had been doing this on the stock converter, just took 10+ seconds to get to 3200 rpm before. I knew I needed to work on the launch limit ignition cut settings to fix this. This is where the sh*t hit the fan...

I opened my laptop. I *think* I had a file open from my buddy's Evo 9 I was tuning previously. Without thinking, I went to launch control and changed the Ignition cut settings from 90% cut to 60% cut. I connected to the ecu and uploaded the changes. The car immediately started acting up. My radiator fan and water pump came on and were pulsing. My oil pressure warning light, that's an Aux out on the ECU starting pulsing. I tried to start the car and it was banging and popping... I tried uploading an older calibration, no change. After 5 hours of normal troubleshooting, fuel, spark, timing sync, compression test... I learned cylinders 2 & 3 were not firing and if I changed my crank trigger settings to 24 tooth, the car runs normal.

To me, this means the ECU is expecting a 360 degree engine cycle for some reason, and if you set to 24 teeth crank trigger, which of course is 720 degrees, it fools it in to running correctly.

That said, I cannot fix it. I've tried changing the trigger 2 setting to a different setting and then back to Cam Pulse 1x, which it what it has worked on from the beginning. I've changed many other settings and then back, storing to the ECU in between. I've tried old calibration files. This morning I updated from 5.6.6 to 5.6.7 software and firmware. Same issue.

Can someone help?

I'm attaching the two latest cal files. One should be before I adjusted the Launch limit ignition cut % and one after.

Thanks in advance.


JoeLaunchJoeTune#1.pclr JoeLaunchJoeTune#2.pclr

Link to comment
Share on other sites

I saw this happen to an evo with a new kiggly kit just a while ago.  The stock evo trigger mode uses both the rising and falling edges on the crank to effectively give it twice as many teeth.  It seems sometimes when you change from evo trigger mode that rising/falling mode doesn’t get re-initialised.  

Try changing to Subaru V1-6 mode, do a store, power cycle, then change back to the correct multitooth settings.  The Subaru mode should overwrite the edge settings.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...