Jump to content

CAN set up to show Gear Display


Recommended Posts

Hi Guy's,

Not very clued up, but a customer has a ECU master gear and shift light display.

I can get the shift lights to work but i can't get the gear to display.

The gear is all set on the ECU and display's the correct gear when moving.

Can anyone help with the CAN settings.

can id.png

can streams.png

geardisplay.png

Link to post
Share on other sites

Ok you dont show all the info that is needed but a couple of things I can see:

  1. In the ECU config you have both RPM and gear set up in the same stream.  But in the ecumaster config you have the RPM and gear set up on different ID's, 3E8 & 3EB.  You dont show what ID you have set in the Link ecu but assuming you are using 1000, then both the RPM and Gear ID's in the ecumaster should be set to the same 3E8.
  2. In the ecumaster settings, the Gear byte position should be 2.
  3. And make sure you check the bit rates to match.  You have the ecu set to 1Mbit, but I cant see what the gear display is set to.
Link to post
Share on other sites
  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...