Jump to content

Link Fury - AN 5v falling steadily on some sensors - Solved


Recommended Posts

Hi everyone. 
Link Fury, 1.5JZ. I wired it in over 2 years ago and it’s been faultless.

I have an issue that only started recently. First with a trim pot switch (the AEM one), and has now appeared in my TPS sub signal. 

- ECU is showing a steady 5v output. 
- with the trim pot and now TPS sub, once the voltage gets to around 2.5v it just starts to drop gradually. 
- this causes an error in the TPS. 

All other sensors using 5v reference are fine. Oil press, fuel press, ethanol, pedal position etc. 

here’s a video of the trim switch.


Link to comment
Share on other sites

it’s giving me the same result. 
that’s the trim pot switch rotating as in the earlier video. 

This is how the TPS is reacting. (Full throttle, letting off slowly)

TP main/sub and AP main/sub all share the same 5v and GND, so i'm leaning towards a fault in the TP Sub AN wire.



Link to comment
Share on other sites

So if its got a constant 5V going into that switch, but the voltage fades away when it is biased more towards ground that would suggest the ground connection is weak/has high resistance/bad connection. 

You could try measuring resistance from the ground pin at the pot to the ECU sensor ground pin, it should be very close to 0ohms. 

Link to comment
Share on other sites

That would suggest you a break somewhere along that sensor ground wire, or a bad crimp at one end, or a bad splice.  Since both the pot and TPS are affected that would suggest the bad connection is somewhere before it splits out to those two devices. 

Sometimes you can find it by wiggling different areas along the wire while watching the omhmeter.

Link to comment
Share on other sites

  • Dean changed the title to Link Fury - AN 5v falling steadily on some sensors - Solved

I chased every sensor ground, and removed almost the entire loom from the car and they all came up good (except for 3ohm resistance on one wire from the original Link loom sensor ground splice. Replaced that to be safe).


- I finally tried another E throttle body and that fixed the issue up the front. (original TB was damaged in a crash about 5 events ago, so it must've finally given up)
- I also tried another trim pot switch and that also fixed that issue too! (I'll do some tests on the switch and probably try to get a refund)


So everything seems to be good, and I have confidence that at least the sensor grounds are good because they've now all been checked!


Thanks again or your help. I've learnt some new things from this experience!


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...