Jump to content

PCLink Message


Recommended Posts

I tried searching online a bit, but couldn't find any communication issues with any G4x ecu's. Just wanted to see if anyone might know what is happening.

Error Message when trying to connect with laptop - Unable to connect to the ECU. Please check that the ECU is properly connected, the power is turned on and the correct COM port has been selected.  

with the engine not running after manually trying to get it to connect and clicking OK to the above error message a couple times it would then connect and I could make changes, however once the engine was running it would lose connection sometimes within a few seconds sometimes it would last about a minute or so. I had to tune the car on the dyno by making a pass, turning engine off, retrieve ECU log, make changes, fire car back up and repeat... needless to say it was not convenient. 

I tried Un-installing and Re-installing the Link software

I also checked device manager to make sure it showed the driver properly working

I also tried upgrading firmware, failed to update many times, I have pics of those error messages as well, eventually I was able to downgrade to .17 firmware from .18 and since I didn't want to risk the box ending back up in BOOT mode I just left it to finish the dyno for now. 

Engine has resistor type spark plugs in case that comes up as a potential cause

1.8 Miata 

Only things that share power source with the ECU are Crank/Cam Sensors and Link CAN-Lambda controlled via a PMU16

ECU is grounded to back of the Cylinder Head


Thanks for the help


Link to comment
Share on other sites

That seems very odd.  I think to rule out a whole lot of possibilities I would power it up on the bench with just 12V on pin 5 and gnd on 34 and see if firmware update goes smoother then.  If not then I would be suspicious there is an issue with the USB chip.  However, if it does appear reliable on the bench then I would start unplugging other devices in the car or get a scope on the power supply to see what is going on.  It sounds almost like excessive AC ripple from a bad alternator diode or something but that would only be in effect when engine is running. 

The .18 firmware does have some extra comms recovery strategies built in to help in noisy situations but it sounds like this is more serious than a small interruption.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...