Jump to content

ECT problem


Guest |297|
 Share

Recommended Posts

HI Guys,

I am having a problem with a marine ECU i have. This has done this once before for no reason what happened it was running fine then went into a limit mode, I checked out what was happening and the ECT was pinned on 110 degrees.

No matter what we did it would not change frrom that number.

Strangley i gave up on this ecu and it sat around for months before i got it back out and had another look, by this time there was a firmware update, so i thought why not it doesn't work anyway so after completing the firmware update it started working again.

I have been using this ecu with no problems for weeks until yesterday i was tuning everything was fine, but when i got home and tried to restarted it it would not run properly, so i hooked up the pc and low and behold the ECT was back at 110 degrees. nothing has changed in the pcl and the sensor is fine, i checked it again today while the engine was stone cold but it still reads 110.

by the way when this first happend i tried it in several machines and every machine done the same thing 110 on the ECT.

I retried to update the firmware again but it did nothing it is still pinned at 110 degrees, i dont want to throw this ecu away, but it is just to unrealiable to use.

Does anyone have any ideas????

Link to comment
Share on other sites

Go to Analogue Inputs/ Fault settings.

See what High and Low values you are using.

Either these settings are not correctly, or there is a problem with the wiring/sensor.

Link to comment
Share on other sites

Defiently nothing wrong with the wiring or sensor, i have tested this ecu in multiple jetskis running the same adaptor and setup all do the same thing with the ECT.

I can fit another ecu into the same skis and there is no faults.

Same goes with fault settings, all ok this ecu has done this 3 times where it works with no problems and then will do this.

I have fitted 4 ecus with this plug and play adaptor with no problems like this and they are still going strong.

I am guessing this ECU is faulty with an imtertmittent problem on the ECT.

Link to comment
Share on other sites

Hi David,

As it sits it has 4.88 volts at the sensor wire, and still reads 110 degrees on the computer.

I can connect or disconnect the sensor with no changes in the temp.

I even set up another AN channel to with a 1 watt pull up resistor as to make it another temp channel this did not work either, it still read 110 degrees.

Link to comment
Share on other sites

Check the sensor ground. If this was broken it would give these symptoms.

Is the adapter made up from one of our 2.5m looms? If so check around were the sensor grounds are spliced together about 100mm from the header plug.

Link to comment
Share on other sites

Hi Simon, no the adaptor that we use is made by Mastertune Engineering and designed by me. There is no problems with sensor earths i have checked resistance on this when it first happened.

I have emailed you about this ecu and i was going to send it to you guys, when i thought i would check the firmware for a last time after i updated it in December it suddenly started working perfectly with no changes to any thing else. It has done this before fail like this and then out of the blue start reading ECT again.

As said earlier there is no problems with the adaptor or wiring, as i have fitted another Vipec and Link G4 ECU to this ski and both of them work fine, that is why i am confident what ever is going on it is in the ECU, i also have 4 more of these adaptors in skis working fine with other ecus.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...