Jump to content

Tablett as display with link G4X


Recommended Posts

Hi everybody,

I have a Linx7 tablett in my gc8 to work as a display for my g4+, works wonders and even uses it for some tuning.

Now my dad's car (also gc8) is running g4x, so I bought him the same tablett even before he bought the ecu.

Now we cannot get it to connect together (tablett is not recognising the ecu, and ecu works on 5 different laptops tested).

I spoke with tech@linkecu and they offered to send the ecu back, but before I get to send it and get blasted by shipping and import fees on the way back,

I would like to know if you guys have found/uses a tablet of that size range (about7") that works with g4x ecus, and doesn't cost the price of a digital dash.

 

any inputs are welcome :)

Link to post
Share on other sites

If the ecu connects to all other laptops besides the tablet then I dont think there is any point sending the ecu back.  

Maybe start by looking at the differences between your tablet that works and the one that doesnt.  Look in device manager and compare the the USB chipset/hub/root hub etc.  

The fact that windows doesnt recognise it suggests there is something not right on the USB side. Have you swapped the OTG cable between tablets etc?  Tried a usb hub?

Link to post
Share on other sites

So, both tabletts (mine and his) behave exactly the same on G4x, namely not recognised at all (in the device manager nothing pops up after flugging in). I didn't test his on g4+ because the cars are not near each other.

Pluging a USB key triggers a USB mass storage and a mouse gives PS/2 mouse in that list. keyboard work good too, and that is on the two different OTG adapters we have also on both tablets.

So yes, tried 2 OTG cables (one from the tablett and Rii F1 OTG) on both tabletts on g4x without differences.

so you mean pluging a usb hub into the OTG cable? should it be a self powered one or simply a kind of USB divider?

Link to post
Share on other sites
On 4/2/2021 at 6:32 AM, Adamw said:

  Tried a usb hub?

Yes Adamn you were right!

I just tried and pluged a usb hub (powered through the otg, no external source) and the tablet ringed as you connect a new device to it.

then I pluged the tuning cable onto the hub ringed again, and ECU connected!!!!

So I have at least this band aid possibility, thank you. 

I then tried afterwards to plug again the ecu into the otg without it being recognized (like it was before) so there seems to be indeed an issue there.

any idea about how to get it work without hub? its a bit chunky to have the hub in the car :D

Link to post
Share on other sites

Yeah not sure either, but I have had that before with a G4+ connected to a tablet.  Its like the USB port stays in client/device mode rather than switching to host mode (like it assumes the ecu is a charger).   

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...