Jump to content

90 MR2 RPM ISSUE


kevin p
 Share

Recommended Posts

It is a misfire, there is no ECU commanded cut.  It appears it is very rich, right before it misfires the lambda is showing 0.69, there are no many ignition systems that will light that up.  Has it been tuned?  Why is it so rich?

Link to comment
Share on other sites

The car has not been fully tune as of this time. The start up and drivability off boost is good. Judging from the log, it goes rich when its being cut at that rpm. 

I also took fuel out but it didn't solve the issue.

Link to comment
Share on other sites

No, it goes lean when there is a misfire or cut.  It goes rich way before then, before then.  

Near the start of the run at 3500RPM you have 2.2ms injector PW at 80kpa MAP and lambda is on target.  Where it starts to misfire at 5800RPM you have 6.8ms inj PW at 133Kpa MAP.  I dont expect the VE changes much between these two points, so for a 65% increase in MAP (air flow) you have a 300% increase in fuel flow.  That doesnt fit with normal logic.

Does the MAP sensor match BAP with the engine off?  

I would at drop the values in the highlighted cells in the fuel table below down to something similar to the 19.3kpa row above them.  

h4wI5w2.png

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...