Jump to content

G4+ CAN BUS transmission stopped working after map changes


joan_jamila
 Share

Recommended Posts

I've developed a datalogger device that reads different sensors of the vehicle and also reads the CAN BUS from the ECU. 6 months ago I tried to read the user defined stream and everything was working perfect. Over the last months I've been working on the map configuration and lots of changes have been made (fuel and ignition tables, auxiliar outputs, analog inputs, cranking tables, ...) . Last week I tried to read info by CAN but the ECU wasn't transmitting anything. I checked the wiring and everything was ok. I also made some changes on the CAN configuration and nothing worked. Then, I uploaded the map configuration that I used to test the CAN BUS 6 months ago and the CAN started transmitting.

I have compared the two configuration in order to find what is wrong but I haven't find a solution.

I attach both configurations: 

Link to comment
Share on other sites

You've changed the bit rate from 1mbit in the older file to 500K in the newer one.  Did you change the bit rate in the receiving device?

You also have lots of CAN errors showing in both maps suggesting something on the bus is not responding correctly in terms of CAN laws. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...