Jump to content

Launch rpm limiter


Recommended Posts

Hi

Im trying to add a momentary launch rpm using my transbrake button on our twin turbo v6.

Can I use a DI as a gp to trigger it from my transbrake button?

I want a launch rpm of around 5500-5700rpm and then after I leave I want the limiter to return to the normal rev limit of 7500 I have it set at.

Any help would be great.

Cheers.

post-1172-143450214686_thumb.jpg

Link to post
Share on other sites

Hi Koo

You can use the transbrake to activate a digital input.

This input can then be used to activate the Launch limit.

You screen shot is in the correct mode to do this.

It would be assuming you have the transbrake switch wired to Di1 it would need to be active for 2 seconds before the limit is engaged.

I would suggest starting with the advanced limit mode turned off.

Link to post
Share on other sites

I have used it for drag racing with a transbrake button for activation. I did away with the transbrake, put in a line lock and use it that way (same button)

With the brake I was launching at 4500 to 5000. with the linelock I launch at 3300. Much easier on drive line parts.

I had some troubles using the advanced mode. But they cleared up when I turned off advanced mode.

Link to post
Share on other sites
  • 2 months later...

Hi muzzytt,

yes you could use the hand brake switch if desired.

Under the Launch RPM Limiter setup table select a digital input that you have spare as the Activation Control.

Then go to the Digital Inputs tab, select the digital input you wish to use.

Set it up as follows,

FUNCTION = GP Input

SWITCH TYPE = Toggle

PULL UP RESISTOR = On

ON LEVEL = Low

ACTIVE EDGE = Falling.

Which LAUNCH MODE are you wishing to run,

Mode 1 , 2 or 3

Regards

Dave.

Link to post
Share on other sites

Ok I've wired it up as you said dave and seems to be working . When I pull handbrake up its says launch control armed. Handbrake

Off it says disarmed.

so ive put it as mode 2 and limitet as ignition cut.

its degault set at -30 degrees.

I gave it a test at 2500 with it armed and got an almighty bang from exhaust.

Is the severity of this adjustable or is this normal ? I'm thinking 2500 rpm might have been a bit low?

Thanks heaps and looking forward to traction control on the I series so I can upgrade to it !

Link to post
Share on other sites
  • 1 year later...

I have wired the xs loom to my ecu to do the handbrake activation, but can't see the digital input active.

I have the EVO IX plug and play ecu, wired the grey wire to the handbrake switch, went to Digital inputs, but doesn't display the D9 or D10 from the xs loom I just plugged in.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...