Jump to content

s13 factory cluster


Recommended Posts

Hey all. I am having trouble getting my link to run my factory speedo, have wired in capacitor/resistor as mentioned in other forum posts. This does respond with the needle moving however not for very long, With it in test mode can apply 50hz and itll sit at about 30kmh and with more hz and it drops off and dosent respond, Key sweep is set to 180 kmh but will only ever reach 60 kmh then drops off, Have checked wiring at cluster and ECU continues to output the hz until test switched off, Have tried the cluster in a factory s13 and run flawless, Running Toyota R154 gearbox. Any advise? Is this symptoms of still receiving a incorrect signal? Cheers

Link to comment
Share on other sites

Yeah sounds like it is not happy with the signal, perhaps it is not always crossing zero or something.  You would really need a scope on it to understand what the problem is.  You could possibly use the trigger scope by looping your speedo signal into trig 1 pin as well, not something I have tried but should work in theory.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...