Jump to content

Launch Control Rpm Problems


Recommended Posts

We can't get the launch control rpm to work on the i88 (latest firmware) as it did on my old G4 extreme. We have tried many settings but when the boost rises the rpm rises.

This is how the log looks:

(launch rpm set at 6000)




I logged some more today with a signal generator hooked up to the triggers to log without starting the engine:

(more parameters logged, launch rpm set at 5000)


How can I see if the fuelcut is working properly on both primary and secondary injectors?

We have the same settings as we did on the G4 box but something is different as we can't get it to work as good as it did.

We have tried many different settings also but it never holds the rpm as it should and did with the G4.

Link to comment
Share on other sites


We have confirmed on the bench that launch limiting dose not work when set to fuel cut.

It has been added to the list to be fixed.

Next firmware will have this resolved.

Firmware 5.0.4 or earlier fuel cut will work.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...