Jump to content

connection issue with gts link ecu

charles hopkirk

Recommended Posts

hi there. ive got a early generation plug and play gts link but cannot get the pc to connect to it have tried diffierent com ports checked ground and power distribution but still nothing.i would like to do some pre start up checks.this is the second one ive come across that i havent been able to connect to in  with the same pc.i have attached a file of a picture  inside the ecu.


Link to comment
Share on other sites

i uninstalled the G1 pc link that i had then downloaded the link that you supplied tried it and no connection.went through power supplies and checked all grounds everything is there as it should be.the seial link isnt that old and in really good condition is there any way i can test the serial link and the connection to the micro? 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...