Jump to content

GTS/GTR G4 PNP issues


Brian M
 Share

Recommended Posts

I have recently built an RB30DET with the following specs:

  • R33 RB25DET head recently overhauled, std cams, valve springs and injectors

  • 9:1 comp
  • Forged RB30 bottom end
  • Custom intake plenum (still retains factory idle control) + Q45 throttle body

  • Custom exhaust manifold with GT35R
  • 3.5' exhaust
  • GTR manual gearbox
Pics say a thousand words http://i223.photobucket.com/albums/dd81/30det/enginebay1.jpg?t=1289299440

 

 

It's installed in a 32 GTST using an r33 rb25det auto loom with a Power FC, datalogit, LC1 wideband and Q45 AFM.  The engine has been run in and there are no issues with the loom, sensors or engine (yet). It has made 270rwkw @ 12 psi running off the external 42mm Tial wastegate, the only issue with this setup is the irratic idle which the Q45 AFM has been the cause. It has good even compression and the head was recently removed to check valve seats and cylinder bores, all are perfect.

I recently purchased the GTS/GTR link, IAT sensor (GM 358-0003) and expansion connector to replace the PowerFC. The install was straight forward and have got it to start but that's where the problem begins.

I have configured the pinouts on the G4 to the factory pinouts http://i223.photobucket.com/albums/dd81/30det/R33ECUPinout.jpg?t=1289295611 but turned off Pin 29/ Analog Input -AN Volt 6 as I'm not using the std oxy sensor.

The LC1 is connected to analog Inputs AN Volt 2 and IAT sensor to AN Temp 3 on the expansion connector, these appear to be operating as normal.

I followed the step by step guide in the installation manual and didn't have any issues The base IGN and Fuel tables were altered to suit my engine.

 

At the end of the installation manual I found something that doesn't make sense:

'TPS Idle Switch Powered From +5V. This is NOT an issue on manual transmission models.

Some automatic transmission models require the TPS switch to be powered from 12V. This

can be achieved by removing the wire from pin 57 (Idle Switch Power) and joining it to the wire

from pin 59 (ECU Power).'

On the RB25 Pin 57 is Exhaust Temperature sensor signal, Pin 48 is Throttle sensor power. As the loom was originally auto and the extra wiring + plug at the TPS is still there should i remove Pin 48 and connect to Pin 59 ECU power?  I haven't done this yet.

 

The issue I'm having is when the engine starts it struggles to maintain idle speed (tried 750 to 1200rpm) any throttle and the engine gasps for air then dies most of the time, it idles between 400-600 rpm and sounds bad.

There are no fault codes, ECCS sync, trig 1 & 2 are fine and Trig errors are 0. I have physically checked that all injectors are squirting fuel, have spark at all 6 plugs, checked timing with timing gun. I have plugged in the PowerFC and the motor runs as if there was nothing wrong. I have warmed up the engine with the PowerFC then tried the link G4 and still have the same problem. I have tried using the Base map supplied with the Link ECU and had no luck.

At this point I pressure tested the intake for vacuum leaks, tried using different vacuum line from the plenum directly to the inbuilt 2.5 bar Map sensor but no leaks. I tried 390,400 and 420 deg Injector timing without luck. I found the installation manual to be vague and know I've missed something in setting up the ECU right. Attatched is my pcl map and a 20 sec log.

I hope this is enough information and  would appreciate it if someone could tell me where I've gone wrong.

 

Thanks.

Brian.

 

 

RB30DET.370cc.pcl

running.shite.llg

Link to comment
Share on other sites

Done the Map calibration 5 times and stored each time http://i223.photobucket.com/albums/dd81/30det/mapcal.jpg?t=1289351843

Done the TPS calibration 5 times and stored each time.

Set to open loop idle and made changes.

This hasn't made a difference, If I crank it without throttle it idles rough, If I give it throttle while cranking it revs up to approx 1500rpm them dies.

The pcl file with changes made is below

Link to comment
Share on other sites

the base values haven't been increased much in that map.  What's the max value you tried?  I'd be increasing the values in the entire row until you get a suitable idle speed.  Try something around 80-95 instead of the 55 to 30 you have in there.

Link to comment
Share on other sites

I'm guessing it's not running long enough for the LC1 to get an accurate reading?  Looking at your fuel table, it looks basically identical to the RB20 base map that comes with PC link, same master setting too.

 

Have you tried bumping up the master setting?  You will need a fair amount more fuel than the RB20.

Link to comment
Share on other sites

The LC1 was warmed up before cranking the engine and yes the fuel was lean.

Changed the master fuel from 7 to 17 and it fires up and idles and stays that way, a tad too rich but the problem is sorted.

Thanks Jason and Vern, without your help I'd be pulling my hair out over the simplest of things.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...