Jump to content

Can my Link G1 connect to a pc?


Igor Polshchikov
 Share

Recommended Posts

Hi, I recently bought a Link G1 with a "WRX ROAD 97" chip in it.
The chip reads: 
MC68HC711E9CFN2
5C47M
SSFA9949 

The board reads:

Link  1996 Subaru v3.2

My question is, can I use a module and a laptop to connect to it? If so, what module and what software? 

If I can't use a laptop, what can I use and where do i get / buy it?

Thanks!  

Link to comment
Share on other sites

  • 3 weeks later...

Hi again, I have obtained a hand held controller.

While setting up the TPS SPAN the value doesn't change while depressing the accelerator pedal.

The manual says to adjust it to 100 while depressing the pedal and then let it go and re adjust down to 10, but is the value on the screen meant to change in response to depressing the pedal after the procedure has been performed?

Also, when setting the idle rpm, there is no change unless I change the solenoid duty cycle manually. The idle just sits on around 1000rpm.

Can that be because the throttle position sensor is damaged or not adjusted to hit the idle switch? 

 

Thanks

Link to comment
Share on other sites

It the TPS is not reading 10 (closed throttle) then the idle control will be locked out.

It could be that the TPS has been set up on a car that had the 5V and ground swapped.

It could be worth doing a full reload to start from a known point.

Link to comment
Share on other sites

Is it expecting 4.7v on closed throttle?

Is it looking at all at the idle switch (4th wire on the TPS) or just looking at the initial start up voltage?

 

I tried reversing the ground and 5v on the connector to the TPS, doing the same thin. Just sits at whatever value I select at the TPS SPAN and wouldn't change on throttle opening.

 

Link to comment
Share on other sites

It only looks at the 0-5V signal the idle switch is not used at all.

The TPS should move with the voltage displaying 10 at idle/ closed throttle and up to 100ish at full throttle

Have you tried a reload?

Link to comment
Share on other sites

There was a sticker but it came off the first time I changed the ECU box. Definitely read "WRXROAD" and 90% sure it said 97. 

If its any help, there was another number on it reading 449.  

The car is running ok, but if the chip is wrong what are my options? 

Link to comment
Share on other sites

If its just WRXROAD that will be ok.

The later ECU for the 97/98 wrx had the chip WRX97

So you should be OK I think.

On the 4 plug, your TPS comes in on pin 55

This is on the small plug top row 2 from the right.

 

Link to comment
Share on other sites

  • 2 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...