Jump to content

No usb connection Atom Serial 15794


Craig Jennings
 Share

Recommended Posts

Preamble:

'Howdy, I brought a link as I ended up in over my head with building my own ecu, I couldn't get it to talk to my computer.
It turns out I'd done nothing wrong but my OS wasn't co-operating and a nice chap flashed me up some new firmware.
But I figure to help myself get the damn ute back on the road I would pull a $1550 trigger and get me a link atom.

Unfortunately here I am again with an ecu that I cannot seem to talk to.
If any of you know Fred from another interesting ecu project he says 'HAHAHAHAHAHHAHA' but he's also offered to be helpful whenever we get in the same place at the same time, until then, I'd rather have this puppy fire of its own volition. 

Status:
Ecu wired and fired, it has a steady blue light when I give her power which I'm guessing is a good thing, I may have missed the  'status of your led indicates' part of the manual, I did have a gander.
Computer shows and 'bings' when the ecu is connected and it shows up happily on both computers I've tested it with in device manager.

Tried:
I've changed the rates and manual/auto and all kinds of combinations to see if it was just a little bit of stuffiness between the two to no avail.
I've tried both a 64 bit win 7 laptop and a 32 bit win xp laptop, they both see the com open (4 and 10 respectively) but PClink gives me 'bongs' which everybody HATES (get a new noise or no noise perhaps?)

What would be helpful would being able to know what my firmware version is.
That seems like a doddle, connect to PClink, you have XYB please get PClink to suit. 
The latest version of something KNOWS what has gone before so should know their languages, unless that's what happens but I haven't even gotten that far! hahaha.

This has been quite a trying engine conversion as I've had to fight ACC (3 years and ended up 'winning' such as it is) and haven't been able to stand for much of that time so progress on ute has been sporadic to say the least, the fact I haven't lit it on fire and pushed it down a hill probably shows the level of my incapacity as opposed to my mental state. Now another ECU that I can't talk to is bringing back memories better left buried! hahaha.
There is a filthy freeEMS puma board which is one crippled and fixed/hacked up piece of hardware that has a pinout that matches my Atom 80km north of me, if that ends up getting plugged in and it talks to me I'll join Fred in some maniacal laughter.

Link to comment
Share on other sites

Headed into a master dealer and they didn't have any 'old' atom looms, hahaha, oh my luck!
I think the new ones came out not long after and were $500 cheaper, just to rub it in, lol.
Anywho, I will go back and try systematically every GOD DAMN PCLink release, I tried the ones that covered back over a year from purchase date so perhaps I just have a really old one, which if true and is working makes me want to karate things in 80's fashion re: 'you have firmware version xyz' popup.
Having no wired internet at home makes this a little harder ;)

And if that doesn't work I suppose I'll break out the croc clips and give her some power with NOTHING else attached.

MDealer: 'Does the blue light go?'
Me: 'Yes, it's a nice solid blue light and the computer recognizes that I've plugged it into the usb port'
MDealer: 'Well then you should be able to talk to it' 
Me: 'Yes, yes I should'.

So at the very least, could you look up what firmware this serial number was released with?
PCB Rev 1.1
Serial # 15794

IF you don't have an automated pop up to deal with firmware version when connecting to latest PCLink a published list of serial numbers and correlating firmware would be mint.
Or tell me if there is one.
Or tell me if there is an automated pop up and that I've just fucked up.

Does it say to 'download latest PCLink' in the manual? Or 'download specific PCLink for your unknowable firmware'. I forget which.

It does seem that clever blokes like you wouldn't have something like this and that it's much more likely my fault. 

And last but not least, what function(s) does the blue light serve and does it have error codes?

Link to comment
Share on other sites

Hi Craig

First step will be to check in device manager that the device is showing under Ports COM and LPT

The USB should have an assigned virtual COM port number.

See attached image.

As you have not started the configuration or tuning you should update to the latest firmware as the first step.

Assuming the device has installed correctly as per the image then you should be able to upgrade without an initial connection.

Just power up ECU open PC Link 4.9.9 then go to ECU controls and update firmware. This runs as a stand alone program that will then try to connect.

Link to comment
Share on other sites

So I spent an hour going through ALL of the PCLink's.
There are quite a few.
When I have the ECU plugged in it has a little think about updating the firmware, when it's not connected it immediately tells me it's not connected. So it knows something is there.
I even tried a few different USB ports and changing the virtual port number and buffers etc etc.
So, there we go, I have proven I can do a MUNDANE CHORE THAT I KNOW WILL NOT RESULT IN ANYTHING POSITIVE so now we can do something constructive of my choosing. 

Will you scream if I pull it apart and play?
I should think not, I'll even use a antistatic mat and strap.
Fancy fancy.

So important questions: (therefore upper case)
ARE THERE SOME PINS I CAN BRIDGE AND GIVE THE FUCKER A RESET?
ARE THERE SOME PINS I CAN CROC AND FEED IT SOME POWER?
ARE THERE PINS FOR SOME OLD FASHIONED SERIAL INTERACTION?
(because I don't feel like trying to fiddle through the socket, that's fucking daft and the master dealer I visited didn't have any 'old' looms (new) so I could feed it that way without chopping into my soldered loom)

Cheerio.

Link to comment
Share on other sites

You can connect via serial if you were to open up the ECU and move the JST plug over to the CAN/RS232 plug on the board.

The pinout of the 6pin round plug then matches what is in the help file for the coms port pinout of the Storm or Xtreme

To power the unit up this can be done while it is out of the case by clipping power across the big diode, power to the stripe side.

Link to comment
Share on other sites

Unit powered up by itself away from loom.
So went through the loom... all still seemed fine in loom land.
So put the multimeter on the loom and the trigger 2 and +14V had been wired around the wrong way.
So out of thousands I got a dud... hahaha, if not for bad luck I'd have none!
Swapped those two wires around and all is well in the world!

So for future reference, +14V going to trigger 2 will make the units blue light power up.
I hope trigger 2 hasn't been affected, the next engine will be making use of it so I guess I'll find out then!

Link to comment
Share on other sites

Yeah I thought that could have been the case with the fuel pump relay as I've run everything else as per the manual.
I've had it disconnected from the first plug in, though I've changed nothing and it works perfectly now! :)


But the main problem was the +14V being in the position of the Trig 2 and vice versa, FROM THE FACTORY.
You may have read that and not been surprised, I thought you may have been though, I certainly was! hahaha. 

Link to comment
Share on other sites

It is always a risk when the looms are made by the 100s

If you are able to the loom should have a batch label on it close to the main connector this will have a date code.

From this we can trace it back.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...