Jump to content

Re: AIM Dash Setup with Vipec


Guest |141|

Recommended Posts

  • 3 months later...
  • Replies 101
  • Created
  • Last Reply

Top Posters In This Topic

Latest information from AIM

******************************************************************************************************

Hi Ray ,

GP_PRESS_AN_Voltx.doc is incomplete in some fields , can you complete it ?

I need to know how to convert "RAW" value for the GP Press AN Voltx channels with all types of sensors that can be connected to the ECU,

through this analog/configurable channels.

Sometimes I receive request about the complete implementation of this ECU Channels , so I want to found a better solution ...

I can not change RaceStudio2 , so it is no possible to dinamically change the unit for the GP PRESS AN Voltx channel , so the other solution available are :

1) I can fix for example GP PRESS AN Volt1 channel how a "Wideband" channel , GP PRESS AN Volt2 channel how a "Oil Pressure" channel etc ...

(but it is very restrictive for the customers)

2) My ECU Driver must manage E command , ECU Driver read "AN Volt Function List" table and when a channel is used how a "temperature" , My ECU Driver

apply the convertion "raw - 50" to the value received by the ECU ecc ...

In RaceStudio2 the customers is able to change the default name of the channel , so for example can change default name "G4_GPPress_AN1" to correct name "Oil Pressure"

But when a customer see the ECU channel with RaceStudio2 ON-LINE , the "Unit" showed, it is always "#" same as a generic "raw" value , because it is no possible

to change dinamically this unit and at the moment it is no possible to change RaceStudio2 and I have no solution for this ...

AIManaloginfo.png

Link to post
Share on other sites

maybe it would be possible to make a data stream from ECU side to work with AIM?

For example if someone choose AN Volt xx channel for Oil Pressure, then like it's done with MAP/MGP/ECT/IAT ECU sends data stream named for example "OilPR", the same applies Fuel Pressure, EGT, WB.. etc?

I don't know how it's done now, but if I connect ECT to Temp_AN1, then I have both on data-stream over ECU_ECT and ECU_GPTemp_AN1.

Look at ECU_9 and ECU_22

aimvipec.png

I really think there is some way to work it out (or every user will ask for their version of ECU driver at AIM). Because I think different people making wiring use different AN Volt channels for different sensors.

For us it is important to see: Oil Pressure/Fuel Pressure (we are using ViPEC 10bar sensors), also Wideband and EGT (Pyro) we are using Bosch 0-5V sensors.

Link to post
Share on other sites
  • 1 month later...
  • 1 month later...
Guest |385|

To clarify the wiring -

ViPEC to AiM

GND to GND

Yellow to RS232 Rx

Grey to RS232 Tx

I believe your firmware also needs to be updated to 4.4.1 or later. Will confirm this once I have a chance to get my cal file.

*EDIT* I am running v4.4.3 and set the Baud Rate to 19200 and Data Stream to Requested - Short. All works fine :) I hope that the information helps others who are looking to install this dash.

Link to post
Share on other sites
  • 1 month later...
Guest |599|

On similar subject Ray, Im having a Plug in ecu on my evo and at the moment have a Autronic smc with a Race-tech dash and logger

As its connected via the serial cable to the rxd txd and ground on the ecu then a adapter to convert data for the dash and logger

could this work same with the vipec ecu or is a lead for can needed

Just trying to get all the info ready for big switch over :lol:

Cheers Adam

Link to post
Share on other sites
  • 1 month later...

Does anyone know how to get lambda/afr/wideband of any kind to display on the MXL? It doesnt really exist in the data stream, although you can see the raw voltage that the ECU is obtaining from the AV input the analyser is attached to, the MXL is not powerful enough to allow user tables or any data filtering

Link to post
Share on other sites

Glen

I have AFR shown, what is the problem?

I set it up like this:

Once you open the MXL, go to System configuration.

There, in the picture of MXL, I choose Field4, page 1, VP_GPPres_AN4 and AFR for the units. My WB is on AnV4 :D

That is it.

Link to post
Share on other sites
On similar subject Ray, Im having a Plug in ecu on my evo and at the moment have a Autronic smc with a Race-tech dash and logger

As its connected via the serial cable to the rxd txd and ground on the ecu then a adapter to convert data for the dash and logger

could this work same with the vipec ecu or is a lead for can needed

Just trying to get all the info ready for big switch over :lol:

Cheers Adam

Any help with this Ray, its all fitted now but cant get any data fron ecu

would it be because it isnt a v44/v88 its a plug in board?

Or do you think its more likely to be ecu adapter software?

Any help would be very appreciated

Cheers Adam

Link to race-tech site thread http://www.race-technology.com/forum/vi ... php?t=1835

Link to post
Share on other sites

Plugin ECU are no different to the standalone V44 and V88.

Make sure you have the baud rate in the Vipec, set to what the Race Technology uses.

Ask them what the Datastream Mode setting has to be set too,

1. Continuous 12 Hz

2. Continuous 25 Hz

3. Requested Short

4. Requested Long

Also make sure you are using 4.6.9 firmware.

Link to post
Share on other sites

Cheers Ray

Does the v44/88 have 2 can ports? would that make a difference

They say its requested short or off, tried both still nothing

Also tried the 57k baud

I pressume on 4.6.9 firmware as only had ecu on 3 weeks

as was waiting delivery from MAD

Cheers Adam

Link to post
Share on other sites

HIC

I do not understand how you define the display unit.

I have set the channel to VP_GPPress_AN5, which is my wideband channel, but there is no provision I can see to edit the units. All I can get is raw data.

Am I missing something that you can help me with?

Ray

The new firmware works fine with the dash.

Link to post
Share on other sites
HIC

I do not understand how you define the display unit.

I have set the channel to VP_GPPress_AN5, which is my wideband channel, but there is no provision I can see to edit the units. All I can get is raw data.

Am I missing something that you can help me with?

Ray

The new firmware works fine with the dash.

look at this picture. It is very simple :D

9fvfac.jpg

Link to post
Share on other sites

Yes, I have that under control.

I have the correct field selected, and I have AFR as the displayed label.

The problem is filtering the data that the dash displays. I cannot apply a unit of measurement nor can I apply a filter of decimal or significant figure. The data comes from the ECU in a raw format, ie a voltage, it does not come as an AFR.

Link to post
Share on other sites
Yes, I have that under control.

I have the correct field selected, and I have AFR as the displayed label.

The problem is filtering the data that the dash displays. I cannot apply a unit of measurement nor can I apply a filter of decimal or significant figure. The data comes from the ECU in a raw format, ie a voltage, it does not come as an AFR.

What AIM software version are you using? Do you have logged data on AIM dash and on ViPEC so, that it could be compared?

I worked with AIM engineers and Pressure, EGT, AFR units is displayed correctly.

Link to post
Share on other sites

both as available at the start of this week. I'm a bit over it. :x give me a motec dash logger any day. you can do anything to anything.

from that screen shot HIC posted, there is no way whatsoever to adjust anything.

FYI, both fuel pressure and oil pressure display only the raw voltage from the sensor.

Link to post
Share on other sites

For sure. I am definately doing something wrong.

Just found newer software on the international website, so I will try that. The version I have are from the Aus site and are not so new it seems, so all may be good.

I take that back - for what I had, I was doing everything right, it just didnt work!

And you're right there, aim definately aint motec. Might have to convince the customer that an upgrade is in order!

In this list if ecu data channels http://www.aim-sportline.com/download/e ... 00_eng.pdf, I cannot see oil pressure, fuel pressure, afr etc. :P

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...