Jump to content

link GTST r33 rb25det ignition problem


Markus Sor
 Share

Recommended Posts

hi

bought a skyline r33 rb25det with Link GTST which are not runing as it should. so I checked the ignition and I have only 0 degrees on crankshaft but 15 on the link ecu. and CAS is set to maximum. Tried to reset ecu but still the same problem. anyone know any offset setting or similar?

 

if I use the original ECU ignition works as it should

 

picture of ECU:

1deefc588a9b0d2bc79686af4b83b98a.jpg

Link to comment
Share on other sites

You should be able to get about a base timing of 5deg, the old G1 units you had to add the base timing to the map to give you the total timing.

Make sure when you check the timing you use a short HT lead between the coil and plug, dont use the timing loop wire.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...