Jump to content

Reluctor problem

Rod Smart

Recommended Posts

I have had this engine running (Toyota 4AG) but have changed the wiring also has been sitting for several months as other thing have been worked on on the racing frame.

Now I have a problem with the reluctor on Trig-2

Trig-1 is working fine, and the ECU is giving a green 'YES' but nothing on Trig-2 input.

I'm wondering about the 'Trigger 2 Arming Threshold' can adjusting this have any bearing on the sensing of the reluctor?


On the dizzy, I have checked that its all clean, and using a metal screw-driver between the inner wheel and the sensor head, the ECU will give a Green 'YES' when I pass the screw driver close to the head position, I'm not 100% sure what the gap spacing should be, but nothing has been adjusted.

I have measured the resistance from the ECU to the sensor plug of the GND/White, Red & Black wires and all are running the same resistance, so I don't know whats happening, or how to get some kind of signal from the sensor (as its Trig-2, this is the sync signal)

Link to comment
Share on other sites

There are a few varieties of Dizzy's for the 4AG, some have the top reluctor with 4 trig vanes, or 2 trig vanes, the one I'm using is the one with 1 trig vane

The lower trig wheel is 24 tooth, which I have found to be standard for Toyota 4AG's

The label on the Dizzy reads 2 lines of numbers, 1 in the top Black section, the 2nd in the lower Silver Section, the numbers are thus below..

Line 1 = 19100-16250

Line 2 = 22910-7010

Line 3 = 4A-GE

PCLink Version = (Build Nov 10 2010) ECU running Latest Firmware


1/. Rods.pcl - My ECU saved file

2/. Picture of Label on side of Dizzy

3/. Dizzy side of connector

4/. ECU side of connector

Note:- on the ECU side of the Dizzy connector, RED & Black are the 2 trig wires (they are correctly wired, as it has been running previously)

ECU <-> Dizzy

Red -> Green = Reluctor Trig Wire

Black -> Red = 24T Reluctor pickup

White (red side) -> top white wire (looks Yellow, but its actually white) = Reluctor common

The other wire on the dizzy side (Yellow) is the 2nd Reluctor pickup, this is positioned 180 degrees from the sync/index pickup, I have tried wiring to this pickup, but it gave the same result, no signal

The 2nd white (black side) wire from the ECU isn't wired, as from the ECU, the Red & Black go into the ECU, and the White & shield go into the green wire terminal beside the trig inputs, the Dizzy has all 3 reluctor 2nd wires tied together between the dizzy and the connector.


Link to comment
Share on other sites

Hi Rod.

The 4AGE = 4 & 1; OR 24 & 1; OR 24 & 4 & 1.  These have been the combos over Toyota's years.

The 4AGZE = 24 & 1 and always has been as far as I am aware.

Do you have an oscilliscope at your disposal?  If not, it's pretty hard to see whats going on.  The first thing that popped out at me was the trig2 setting of 'sync mode'... this is incorrect.  You need to set this to Cam Pulse 1x'.  I'd be inclined to set those arming thresholds to the default numbers and leave the filtering on 'low' for the time being.

Having a 'GREEN' and a 'YES' does NOT necessarily mean that trigger inputs are wired correrctly when it comes to reluctor sensors.  It means it can see the signal, but it may still have an inverted polarity on one or either of the sensors (this is where a scope is handy). 

The fact it has run before is not a clear statement to me, because if you mean you got it to start but it was really hairy... the possibility exists that it could have done this with a reversed polarity reluctor sensor too.  Unlikely but possible.  On the other hand if it was running sweet, I can understand why you are a bit baffled.


Link to comment
Share on other sites

Ok, its stopped raining here in Melbourne long enough to play with the wiring (40mm in the last 24Hrs at this location)

I pulled the Dizzy connector apart and reversed the wires to the Reluctor for Trig-2, no change at all (Trig-1 wire disconnected)

I reassembled the connector the original orientation (no change again, was hoping it wouldn't change)

I went to the 'Arming voltage'

Took the value up 0.5V, nothing

Took the value down 0.5V, got signal, RPM again, but as I have been cranking this battery for a while now, its dead flat. I just put it on the charger, I'll try once again once its charged

Oh, also, there used to be (or I have yet to find it) a pre-setup for the dizzy, where you can lock the timing to 10 Deg. BTDC

I'd like to set the Dizzy as close to 10 Degrees before doing the software setup for it (thats after I get a spark lead to hook the timing light up to)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...