Jump to content

a bunch of odd errors in V10 plugin


Hyper
 Share

Recommended Posts

hi guys

I am in the process of installing V10 Subaru plugin (4 plug ECU) in my rally car and stumbled across few problems I am not sure how to sort out... the car is a stock 2005/6 USDM STI with regards to wiring, no issues on stock ECU I pulled out

I set the jumpers for proper year/wiring, based on the instructions

loaded base map, made some minor adjustments for my boost solenoid/avcs targets and left all triggers and settings untouched (attached the pcl file), yet here are the fault codes I am getting:

code 14

code 17

code 19

code 43

code 46

code 75

code 77

code 11

 

thus, I have no control over my throttle... went into the manual, read on the fault codes, followed the procedure of TPS calibration 4 times - no effect. What is also odd, in the logger after I calibrate my TPS - TP main doesn't not move at all, yet I can see the EThrottle target move based on the pedal position. TP Main would also occasionally jump from 0 to 100% and back 

 

 

ECU is running in........NORMAL MODE

Current ECU firmware information
  -----------------------
ECU firmware version     : 4.10.2.0
Bootcode Version            : 1.4
Board S/N                     : 13817
ECU type                      : 25

 

 

 

link_errors.jpg

rev1.pcl

Link to comment
Share on other sites

Hi Hyper,

This one is a bit odd.  From the look of the errors it almost seems like something is shorting the 5V supply.  Do all sensors etc read properly?

The .pcl that you attached has never been loaded into your ECU.  Can you post the map out of the ECU that is showing these errors and also provide a copy of your log?

Link to comment
Share on other sites

I went through everything again today, it seems I narrowed down the problems to E-throttle only, no other faults 

I re-loaded the pcl file again (attached in my OP), stored it, turned engine on - the ECU seemed to be seeing the throttle, yet when I started the car the pedal would not respond

after that I did the TPS calibration, the ECU was seeing the throttle and then all of a sudden it would loose it again throwing the 77 code - before it happened I heard a relay click inside the ECU, hmm..... so I shut down the car, turned key on (engine not running) and started another log (called engine_off_relay_clicks, attached) while playing with the throttle pedal - I could hear the throttle butterfly moving in the engine bay, then all of a sudden again a relay clicks inside the ECU and I loose control over the throttle (it happens on 54th second of the log, throttle just goes to limp mode 7% with no response)

 

Log 23-04-17 4;19;13 pm.llg

engine off_relay_clicks.llg

Edited by Hyper
Link to comment
Share on other sites

The calibration of your foot position sensors is out.  It looks to me like this is putting the e-throttle into error mode.  When your foot is on the floor both FPS read 100%, but when you lift off one drops to 18% and the other ~24%, these should both closely follow each other down to zero.:

jYgkNet.png

 

I'm not sure that is your only problem but I suggest you start there and do another log once that is fixed.

 

Edited by Adamw
Link to comment
Share on other sites

I would have never guessed that :lol: 

anyway, I tried it tonight - seems it did the trick! I also noticed that if I try the TPS calibration, it offsets the FP/TP settings and throws me errors again, so I assume TPS calibration is for DBC cars only

 

looks better now, thanks Adam!

now back to my LC1 experiments... :)

 

tp_fixed.jpg

Log 26-04-17 2;05;14 am.llg

Link to comment
Share on other sites

  • 2 weeks later...

unfortunately my problems continue, I am stuck with error code 5 upon TP calibration... read the manual, it states: 

Error Code 5 – Max 80% DC & TPS(Main) Movement zero.  The motor has reached 80% DC and the TPS(Main) has recorded no throttle plate movement/change in voltage.

Cause(s) of Error Code
·TPS(Main) not connected, faulty or has incorrect fault levels set.
·E-Throttle Motor not connected to the ECU.

Everything is connected, I ended up removing the DBW, cleaning it and is started working. After a short while the problem poped up again and never went away, so I can't get the DBW to work

 

I looked into wiring, and made a table of Link wiring/pinout VS OEM wiring, here is what I found:

 

PCB V1.x (Plug-in)Subaru V10 WRX/STiECU Pinexplained 
Aux 4EThrottle Signal 1B26/27???speed signal/fuel pump controloem diagram says D5, but link manual says D5 is Aux10 which is not present
Aux 9EThrottle Signal 2D4throttle motor (-) duty form 
An Volt 2TPS (Main)C18throttle main 
An Volt 3TPS (Sub)C29throttle sub 
An Volt 9FPS (Sub)C28pedal position sensor sub 
An Volt 10FPS (Main)C17pedal position sensor main 

 

as you see, Aux 4 is what I don't understand - it links to B26/27 depending on jumper, but none of them go to anything throttle related, as the OEM manual says D5 is Electronic throttle control motor (+), Duty waveform, frequency 500Hz

Link manual, however, says D5 corresponds to Aux10 which is not even present in the software

 

what's even worse, is that now I even have a trouble code if I pop the stock ECU back in, P2109, which makes me think that I might have done some damage with the Link :(

 

please advise, I ran out of options already fighting with this over past 2 weeks

Link to comment
Share on other sites

The Aux4/9/10 thing is a bit confusing on the plugin ecu's - Aux 4 & 9 share some hardware resources so they are exclusive of each other - you can only use one or the other.  In the wire-in ECU's this is well hidden in the wiring info and software so it doesnt cause too much confusion, but in the plugin ECU's it isnt as well hidden since pin functions/wiring is normally fixed so users dont normally need to look too closely at the aux functions.

With a plugin ECU, if E-throttle is turned on, Aux 4 in the software is actually Aux 9 on the hardware.  Aux 9 in the software is actually Aux 10 in the hardware.  So even though in the software it may appear like you are using Aux 4 & 9 - you are actually using 9 & 10.  Clear as mud?  Good...  

Since both the Link ecu and the OEM ecu are reporting an issue with your TP sensor, one would assume this is your problem.

As an aid in diagnosing I suggest you set up a digital gauge like below.  When you press accelerator from rest to WOT, you should see both TP sensors increase smoothly from 0-100% and they should read almost identical values throughout the whole range of movement.

ISNqpEO.png

 

Also if you do a log of you slowly opening and closing the throttle (put e-throttle in setup mode to avoid it erroring)  then email it and a copy of you map to BGfzSPG.png we will take a look.

How to do the log: https://www.youtube.com/watch?v=_P1LRANeO4A

Link to comment
Share on other sites

confusing at first, but after re-reading it few times I got it :)

I sorted it out, turns out I had a loose connection somewhere (for no reason) - I traced all wires from the DBW to the ECU and one signal was missing, I assume there was a loose connection in the plug on the strut tower which goes to the throttle, pinned out, pinned in - started working

as always, thanks for clarification Adam! 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...