Jump to content

Car doesn't shut off instantly after key off


Ratty
 Share

Recommended Posts

Not sure if this is to do with the Ecu or not but my link g4+ plugin sr20det in my s14 doesnt not turb off when i turn off the key. It takes about 5 seconds to finally die like its running out of petrol. Any ideas?  Cheers

 

Link to comment
Share on other sites

Hi Ratty,  This one sounds like the ECU is still staying live when you turn off ignition.  Is yours the NS13+ or NS15+ ecu?  Does the wiring appear to be relatively unmodified?  Maybe something like an immobilizer or aftermarket fuel pump relay has been added and is not wired correctly?

Once you tell us what ECU you have I will try to work out a troubleshooting plan.

Link to comment
Share on other sites

I have the NS15+ ecu. Have had a look under the dash and there is a horrendously badly wired in alarm that has since been bypassed. I will most likely get the car sent into an auto sparky to delete the alarm fully and fix the ecu not shutting off problem. Hopefully they know how to do it! Cheers

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...