Jump to content

Possum link to Serial link communication


marc1
 Share

Recommended Posts

Hi there, I cannot seem to get my possum link (V3/4 WRX) to communicate via laptop using the serial link? My chip has "WRX97P  775" written on it? Is this laptop tunable? I am using the PC Link v2.5 software (on windows 7) but it just comes up with a message saying "searching for link ecu then no ecu found". I have checked the obvious like my serial ports are configured the same in both PC link software and on the laptop settings and that my serial to usb cable driver is installed, ignition on etc but no luck!

I notice when the serial link is plugged into the ecu via ribbon cable the engine fuel pump delays about 3 or so seconds from when you switch the key to the ON position is this normal? Vs primes stright away if no serial link is connected.  Also if you try to "connect to ecu" on the software with nothing connected to the serial adaptor the "cannon find ecu" message pops up stright away but if its all connected up it searches for a few seconds before the message pops up so somthings seeing somthing but wont connect to the ECU !?

Thanks and any help is appreciated,

Cheers Marc 

Link to comment
Share on other sites

For a possum link to be able to be PC tuned it needs to be q or later suffix.

So WRX97p is not able to be but WRX97q/r/s are able to be.

 

 

Thanks Simon, Ive got another question for you here. I have managed to find and purchase myself a link G3 (wire in unit) - with a adaptor link for v3/4 subaru wrx. Seems i am plauged by communication errors! Side note- If the firmware has not been updated will the link G3 still do a tacho sweep?

This ecu is supposed to have the software/ firmware upgrade to G4 and it does do the tacho sweep and pump primes with key on which is a start but before I can fire it up due to my difference in injector size from the last owners engine I would like to adjust the fuel.. here is where my problems start. With the USB cable connected to the ecu when i plug it into my laptop I get nothing...(key on or off) like no USB notification sound or cant be found in the Device manager! Its like the ecu is not there at all... then of course if i load PC link it wont connect. My other vehicle is plug in G4 powered (car is in bits) so i decided to plug the same cable into that ecu and even with no battery in the car when you plug the USB into the laptop it recognizes it and makes the windows sound and you can find the "LINK USB" in the device manger.

Do you have any ideas / solutions to why the G3 wont become known to the laptop or communicate??

Thank you, Marc

 

 

Link to comment
Share on other sites

On the G3 are you using a USB A-B cable and not the G4 tuning cable?

Hi simon, I am using the G4 tuning cable that goes in the round plug with the like 1/4 turn locking ring. Cheers

Link to comment
Share on other sites

That is actually a serial connection on that port.

You need to use a plain USB cable into the square port on the ECU. Most printers will be using this type of cable.

Thanks Simon! seems to have done the trick using the suggested cable! cheers :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...