Jump to content

3SGTE ignition / possible sync issues


Stew3223
 Share

Recommended Posts

Hi All,

Just yesterday I installed a G4+ Storm into a friends MR2 with a "gen 3" 3SGTE.  Install went smoothly, all wiring seemed okay, and the engine starts and runs but its really rough and is clearly misfiring at idle (roughness, lean spikes in AFR, lots of smoke and rich raw fuel smell from the exhaust).  I've checked the trigger values which are OK, I have no trigger errors, and the trigger signals themselves look okay...(see attached photo).  We had Trigger 1 wired to "NE" and Trigger 2 wired to "G2" on the distributor.  There's a lot of conflicting info about which Cam pulse to use, so we tried wiring Trigger 2 to G1 and it seemingly made no difference.  We double checked that G- is wired to a sensor ground, however there is no shield (this is the way it was wired from the factory, evidently).  

Any suggestions what next to check?  I've attached a short log and the calibration file also.

Thanks!

 

Trigger Log 6_03.jpg

Log 2017-06-3 10;48;47 pm.llg

Derek MR2 Rev2.pclr

Link to comment
Share on other sites

try increasing your fuel master to get the AFR closer to lambda 1 at idle, looks to be fairly lean through that log.  I'd personally get it running nicely with an idle target closer to 0.95 lambda first then dial it in from there

Link to comment
Share on other sites

Trigger looks ok, so I wouldnt bother looking much closer at that yet.  

Even though your post says "lots of smoke and rich raw fuel smell from the exhaust", you have a very short pulsewidth at idle so it could be that the injectors are working in a non-linear region causing the swinging AFR.  As per JMP's suggestion - bumping up the Master fuel would soon confirm that.  

Two other things that stood out to me:

  1. The Log shows MAP at idle of 30KPa, that seems unrealistic for a poor running engine.   I would expect it to be more like 45-65, so I suggest you check the calibration of the MAP sensor against a known good gauge.
  2. You are on old firmware, I suggest you upgrade to the latest.
  3. When I open your .pclr, it says "ecu disabled", I didnt think it would run like that so I suspect this flag is in error but can you confirm that this ECU has been unlocked?
Link to comment
Share on other sites

Trigger looks ok, so I wouldnt bother looking much closer at that yet.  

Even though your post says "lots of smoke and rich raw fuel smell from the exhaust", you have a very short pulsewidth at idle so it could be that the injectors are working in a non-linear region causing the swinging AFR.  As per JMP's suggestion - bumping up the Master fuel would soon confirm that.  

Two other things that stood out to me:

  1. The Log shows MAP at idle of 30KPa, that seems unrealistic for a poor running engine.   I would expect it to be more like 45-65, so I suggest you check the calibration of the MAP sensor against a known good gauge.
  2. You are on old firmware, I suggest you upgrade to the latest.
  3. When I open your .pclr, it says "ecu disabled", I didnt think it would run like that so I suspect this flag is in error but can you confirm that this ECU has been unlocked?

I unlocked the module but I must not have saved the .pclr afterwords.  

I performed MAP sensor "calibration" but did not crosscheck the MAP value with his boost gauge - I'll do that!

Okay, so I'll give the master fuel a try, although it didn't seem to be a true lean condition.  I believe its registering lean on the Lambda sensor due to and ignition misfire, not under-fueling. While we had it running I slewed the base fuel high in the idle region and it didn't seem to resolve it.  

I'll try some more stuff and post a new log when I can!  Thanks guys...

Link to comment
Share on other sites

Okay, so we we're able to resolve the issue last night.  We re-calibrated the trigger with a timing light and adjusting the distributor until we had default timing to 10*.  After this, we also added a shield ground to the NE and G2 signals.  Anyways, now the car runs completely normally. We also updated the firmware.

One question...After updating the firmware, I can no longer chose "Auto" mode in the CLL options.  I only have stoich (narrow band) and stoich (wide band) available.  Is auto mode disabled in the new firmware for some reason?

FYI...for future reference, for a 3rd gen 3SGTE the G2 signal IS correct.  We found this in one his shop manuals...

 

3sgte trigger signals.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...