Jump to content

Issues with link g4 atom rb25det

Brad Foreman

Recommended Posts

Hi guys 


Just tonight finally got to the point of starting my car and yay it started.


So before it started I did the cas calibration etc and tps.


It fired up yay 

Sounds like a Subaru . Smells like gas and bangs like a launch controller on idle 


So I have checked injector pulse . Have checked firing order 

Have checked coil pulse and firing order 


Now where i think the issue lies is I have it wired to semi sequential .

I have the injector drivers wired like so 


Inj1 - #1 and #5

Inj2 - #2 and #4

Inj3 - #3 and #6


Car has link g4 atom 

R35 gtr injectors 

Don't think the resr will matter 

I have the firing order correct under the configuration 


Where i am stumped is i red on an old post that the injection timing with semi sequential should be set to 720.

I tried 720. 540. 390 and even 0 and it still runs the same 


I don' have a wideband (I just want to make sure it runs so I can take it for a tune) but I pulled plugs and they'e black as . So I dropped master fuel from 11 to 9 and it was too lean it woukd starve if u push the throttle 

Leads me to think it's something to do with injector timing but it really has be fucked tbh.


Any help would be much appreciated . I can upload videos or the tune file if need be 


If it can't be solved I might wire it to be batch fire 

I'm currently using a tune off a friend who was wired using batch fire 


Cheers in advance 

Link to comment
Share on other sites

I might be wrong but the tune came off a car running same motor and ecu and he had his cas in the middle so having mine in the middle give or take a few degree out it should still run without antilag back fires ??


Should I have the injection set to sequential ? Or batch ?

Link to comment
Share on other sites

Injection should be set to sequential if you want semi-sequential operation.  Note however your problem is not related to injection timing or injector wiring/pairing, you can squirt fuel in at any time and it will still run pretty reasonable regardless.  If you have a backfire it means either there is a spark at the wrong time our a valve event at the wrong time (cam timing).

So confirm coils are wired correct again - use the ignition test function.

Confirm base timing and confirm timing is stable.

Confirm there are no trigger errors - software is reporting realistic and stable RPM.

Confirm cam timing looks ok.

In the meantime you can also attach your map and a log so we can check there are no odd settings causing it. 

Link to comment
Share on other sites

Cam timing is spot on 

I have checked coil wiring after this happened and coils are paired correctly 


No trigger errors . When performing the cas sync everything was fine 

No errors at all come up 

Base timing I could check that but when running and watching timing map the timing is stable its not all over the show 




Link to comment
Share on other sites

Your ECCS widest slot is set to zero so the engine wont sync like that.  For an RB25 it should be 24deg.

To adjust that setting you need to set the "test eccs sync" to "on" so it unlocks, then you can manually type 24 into the widest slot field, then turn "Test ECCS sync" off again, do a store.

Also Trigger offset doesnt look normal for a RB25 so you need to confirm that with a timing light (it is probably close enough to run).


Link to comment
Share on other sites

24 minutes ago, Brad Foreman said:

Ahh yes after this I did the sync and it's 24 sorry cab send an updated file if need be

Huh? what are you saying?  It was correct in the actual ECU but the map you attached was wrong?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...