Jump to content

AIM MXG Dash not working


Recommended Posts


I've connected my AiM MXG dash and setup the CAN as per the G4+ manual. In RS3 I've selected G4 as the device.


I get the following error messages:

- Acknowledgement Error

- Error Passive

- Bus Warning

- Transmit Error Counter 128


Everything else in CAN1 Status shows OK. The dash is not showing any G4+ data.


Any ideas how I can troubleshoot this?



Link to comment
Share on other sites

I've got another question about the dash & G4+ integration.

I'm trying to set up a VSS via the 2-wire reluctor sensor on the gearbox. I've connected it to DI1 and set up as a GP Speed and default settings (pullup OFF, AE Rising).

The dash has the following channels available:





Does it mean that the dash doesn't not read DI1? Do I need to move the terminal from DI1 to DI6/2/3/4?


Link to comment
Share on other sites

In the ECU set up assign the speed in put as a wheel speed. Then in the speed sources select both driven and non driven to that wheel speed. 

This should get the dash reading speed.

Link to comment
Share on other sites

  • 4 weeks later...

There are a few firmware bugs still but they all have easy work-arounds.  It seems to be quite a nice dash for the price.

Their built-in Link receive has some incorrect scaling so fuel press, oil press and lambda are displayed wrong, this can be fixed by using a custom stream in the ECU.

The other thing that doesnt work right at present is custom CAN messages in compound/row counter format.  Most people wouldnt need this as our default stream covers most data people want on a dash but if you want to send some custom data you have to send it using multiple ID's.  Still no big deal.  I believe AIM know of these problems so hopefully they will fix it one day.


This thread has a bit more info on both problems:


Link to comment
Share on other sites

Hi Adam

I just expierienced the same problem this week, after firmware update fuel press, oil press etc. Is no shown correct. 

I loaded the generic dash stream into the User Transmit Stream 1 and adjusted the multiplier. For IAT and Oil press it worked, but fuel press is something messed up on the AIM. Parametet is unsigned, but aim shows negativ values...

Consequently i tried to set up a customs stream, where ai try to duplicate the genetic dash stream on the AIM as receiver. The First 3 parameters do function, but the second line wont. I know it's not a link product, but could you please elaborate what the the row counter is for? And how must the receive mask been set if i want receive meddage in the AIM only for ID 1000 for example. 

Thank you in advance. 

Link to comment
Share on other sites

You are best to leave the config at the AIM alone and adjust it at the Link end.  Im pretty sure it will work correctly if you use a -1 divider for FP (even though it is unsigned this should still be transmitted), example below.  Also attached this stream file.

There are also math channels in the AIM so you could do it at that end, but I know the file below usually works ok.


AIM Press x 10 Lam x 0.1.lcs

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...