Jump to content

RB25 not idling, stalling on TPS movement


Recommended Posts

Hi there.

I've built a RB30DET using a 25 r33 top end. I've wired into a G4+ Xtreme and had a few issues... some i've sorted too. Map broken, map and tps not getting 5V (dodgy wire), some CAS troubles etc.
So the MAP now reads correctly and works, triggers work etc. I can't get it to sit at idle though... before I fixed the MAP problem, it was showing 0kpa MGP, and was starting within a couple of crank... it wouldn't quite idle but I could keep it alive easily with throttle and it was quite smooth. Since I've fixed the MAP, it takes about 3 times longer to crank over and start it, and when I try for a little throttle it will stall. A fair chunk of throttle will hesitate it and bring the revs up, but inevitably it'll stall. Not sure if this info is needed but there it is anyway.
Just wondering if there are any ideas out there on what could be wrong now... I'm a little lost. I'll upload my map and the log I took... started twice, first without throttle second trying to keep it alive.

Any help is much appreciated!



Log 2018-06-13 5%3b01%3b31 pm.llg

Link to comment
Share on other sites

Start by giving it a lot more fuel, your lambda is pegged at max lean in the log.  Adjust the "master fuel" up until it runs cleaner (based on your comments above I think it will need to be about twice the size it is now so try about 15ms).  If you havent already done so you will want to put a timing light on it and set the base timing also. 

Link to comment
Share on other sites

Geez didn't even notice those AFRs. I went to 15ms on the master fuel which brought me to around 12.5 AFR, same problem though. It did struggle and idle for about 10 seconds though.
I set the base timing to 15 BTDC.
Thanks for the swift reply!

Link to comment
Share on other sites

Hi Adam thanks for the reply again.

I've had some success... I feel stupid, was rushing a little and overlooked some things so I'll go through and list them for anyone who has similar problems and stumbles across this thread.
I hate when people have problems and say "I fixed it" and thats it haha.

- Something I forgot to fix before this thread was fuel pressure. I was "maxed out" on my Tomei reg and only running about 31psi... So I unscrewed the adjuster, removed the lock nut and wound it back in, bottoming it out. Now I had 115psi. So not sure if the thread isn't long enough or what... but anyway it's back to 42-43psi now without the locknut. Problem fixed.
- As mentioned before, I had a faulty MAP sensor. I then changed this which gave me correct MAP settings on PCLink but wouldn't fluctuate. Measured voltage at plug with ignition on and had 0.3V. TPS runs from same line and had 2.6V. Jumped a new wire across which now gives me 5V. Problem fixed.
- I took Adams advice and updated the firmware... I was at about 5.1.1 instead of 5.6.6! This didn't fix any issues but good to do!
- I then went on with idle control as per Adams advice... adjusting it up all the way to 100% open and no change. Sounds like something wrong with the valve... Checked the voltage at the plug which was all good... I had correct earth... so I pulled it off and jumped the solenoid... this all worked. Now the funny part... I'd blocked off the port that usually runs from the AAC to the intake piping (this is a motor transplant)... yep it's always something tiny like that. Cleaned the valve, chucked it back on with this port open to atmo, fired it up with master fuel at 15ms and a little increase to the AAC% open and bang... we have idle and revs.

Appreciate the help you've given me Adam... it made me step back and work a little more methodically. I'm sure I'll have more questions soon!



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...