Jump to content

Vi-PEC V44 firmware upgrade error


Recommended Posts

I have a Vi-PEC V44 ECU and the whole mapping to do. 
First I have tried to upgrade the firmware to the lastest version (4.9.7 to 4.10.2) but there was an error during the upgrade process and now the ECU is still in boot mode but I cannot restart the upgrade process because of "Checksum_Failed" in file info. 

I already tried : 
- Change the PC (Windows 10 64bit -> Windows XP 32 bits) => no change. 
- Reduce the speed of the comm => no change. 
- Select other firmware => still the same error : Request firmware info failed with error "Checksum_Failed" 

Is there something to do to finish the upgrade process please ? 

Vi-pec ecu error.PNG

Link to comment
Share on other sites

Hmm, ok, this is not an error I have seen before but the checksum failed message makes me suspect the actual firmware file may be corrupt.  So can you try this... 

  1. First step, disconnect ECU completely from power (unplug) just incase something is not allowing it to power down properly. 
  2. Reconnect ECU. 
  3. I have attached a copy of the 4.10.2 firmware, please save this to say your "desktop" (dont put it in the Vipec firmware directory).  
  4. Open up vts software, then the Firmware updater application.  Do not choose the 4.10.2 from the list of available firmwares, but instead use the browse to navigate to the file on your desktop (see pic below),  then do the update as normal.
  5. When you get to the point where it tells you to "powercycle ECU", again completely unplug ECU and re-plug before clicking OK.



Link to comment
Share on other sites

Thank you for your answer, unfortunately that doesn't work too.

I think its a false positive error message.

Just in case I tried to do the firmware update with the PClink G4 software, but same result...

I will unmount the ECU form the car to do more tests on the desk. If you have another idea don't hesitate ;-)


Thank you.

Vi-pec ecu error 2.PNG

Link to comment
Share on other sites

On my desk the firmware was updated successfully, I think I have to check the wiring on the car, maybe a power ground is missing...

This is stange because when the car was arrived at the office the engine was running almost fine at idle...

My first problem was to upload another map from the PC, on the car just after the upload, the power cycle is not done properly and I cannot store the new map on the memory.

I will check the wiring !

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...