Jump to content

Fuel pressure sensor


JBattag121
 Share

Recommended Posts

Please help, I’ve installed a 150psi 3 wire fuel pressure sensor and it will not read correctly. When the engine is first started, it appears to work fine but within a few seconds the displayed numbers will rapidly move up and down. I can’t read what it is. I’ve checked for a short in the harness and all looks good. 

Thanks,

Jim

 

 

 

 

 

Link to comment
Share on other sites

If you watch that frame by frame the value is jumping between about 48 and mid 50's. These seem like reasonable numbers but depending on your fuel system design and regulator you may disagree. You're looking at absolute pressure, so if you have the vacuum line hooked up to the regulator you should except to see a few psi fluctuation due to pressure variances through the intake.

If you look at the logging screen with the graphs instead of the instant values it will be a lot easier to see trends, history and general "how much it moves about"

Link to comment
Share on other sites

Good eye, I didn’t think of that.  My tuner thinks that it should read steadily. But I’m wondering if maybe it will never, because it’s a deadhead system. That’s the approximate to fuel range it should read it idle.  I’m going to copy your message and forward to him and see what he thinks.

Thank you,

Jim 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...