Jump to content

Using Factory Knock Sensor VR4Link/ DSM


wrx110487
 Share

Recommended Posts

2 hours ago, kelvin1982 said:

Hi Adamw, would you mind sending me how to turn in on for knock setting with stock knock sensor, now using the Evo1-3 g4+ plug in. 

Thanks. 

This post is not relevant to you, the Evo plug-in already has the factory knock sensor connected to the ecu.  If you want help learning how to tune it then HP Academy or Evans Performance Academy have relevant video courses.

Link to comment
Share on other sites

Hi Adamw, would you mind sending me how to turn in on for knock setting with stock knock sensor, now using the Evo1-3 g4+ plug in. 

Thanks. 

 

Hi Adamw, thanks for you reply. Because evo 1-3 plug in have stock knock sensor is connected to pin 58, I just wanna to know how to turn it on. 

Thanks. 

 

Link to comment
Share on other sites

9 hours ago, kelvin1982 said:

I just wanna to know how to turn it on. 

It is not just a matter of "turning it on".  Every part of it needs to be tuned to make it work.  There is a basic explanation in the help file page here:  G4+ ECU Tuning Functions > Knock Control

Or if you need more info related to tuning then maybe one of these:

https://evansperformanceacademy.vhx.tv/packages/link-g4-training-course/videos/link-part-link-g4-ems-training-knock-control

https://www.hpacademy.com/previous-webinars/049-setting-up-knock-control-link-g4-vipec/

Link to comment
Share on other sites

On 12/19/2018 at 1:27 AM, Adamw said:

Unfortunately the knock pin is not connected on the VR4 ECU.  You cannot connect it to any other input, it needs to be to the dedicated knock input.  If you were willing and know someone that is reasonably capable with soldering I could give you some instructions on how to solder in a link wire to connect the knock pin to the knock input.  

I also need these instructions please. 

Although I'm getting values when I log knock parameters, it's always steady numbers that don't change with RPM. I always found this odd.  After reading this I looked for my knock sensor input and it's not even setup so I'm clearly just logging a random voltage that exists on that dedicated non-connected knock pin input (whichever it may be?).  I've been running it like this for 2 years thinking my engine doesn't knock ... and I have read all the provided instructions.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...