Jump to content

New cams installed, and now engine thinks it is in boost while sitting at idle...


Recommended Posts

Today's riddle is as follows..

A Subaru application...I just had some new cams installed into my engine, replacing an older set of cams that suffered a lobe failure on the right head intake side. 

With the new set of cams installed, engine fires up just fine, but noticing that the engine runs super rich. Richer than one would expect, given that the cam specs are similar to the outgoing cams. Rich enough that the ECU cannot compensate with closed loop idle. Once I looked at the fuel map to see where the ECU was operating, I quickly realize that the ECU thinks the engine is in boost (about 6psi), and AFR's are sitting in the 11's while the engine idles away.

Things I have tried:

- Checked for vacuum leaks. Boost-leak tested the intercooler plumbing up to 35psi, and no leaks.

- Checked the MAP sensor - purchased a Mityvac hand vacuum/pressure tester and the readings on the gauge of the meter align with what the G4+ Xtreme is seeing.

- Checked to ensure that all cylinders are receiving spark. All are, and in the correct order, and firing in the correct order. The engine has no issues starting up, but simply appears to be running off the wrong part of the fuel map once running.

- Cam timing came to mind, but the thing here is that timing is non-adjustable on my setup, and there are no cam gears to adjust. I did remove a set of Kelford non-avcs cams and GSC AVCS cams of similar lift and duration went back in (but th AVCS holes were all plugged up, and standard non-avcs cam gears used). With that said, I can't seem to figure out what to look at next. Engine builder/Subaru race shop swears up and down that everything went back together correctly, and they also noticed that it was running differently on engine start up. Since they had no access to the ECU, they resorted to turning down fuel pressure in from 54psi base to 34 psi base order to get it to idle.

- We have confirmed that the ECU is not picking up any triggering errors.


Other possibilities:

- Cam timing - the cams that were in there before were non-avcs cams being used in JDM heads triggered exclusively off the Subaru LF intake cam gear and sensor. The new cams that went in are GSC AVCS cams with AVCS holes plugged up, and triggered again off the Subaru cam gear. Advertised cam specs are within spitting distance of each other. Not different enough to cause the car to run as it is right now. 


I will be checking the base timing of the engine with a timing light shortly, and will report back.

In the meantime, here are logs and map:


https://www.dropbox.com/s/2uffohc3y47fg0g/Mike 1%3B21%3B26 pm.llg?dl=0

https://www.dropbox.com/s/btn3zjo6i376w1v/Log 2018 - 12-22%3B log 1 of 3.llg?dl=0

https://www.dropbox.com/s/vh1nflx87b97kn4/Log 2018 - 12-22%3B Log 2 of 3.llg?dl=0

https://www.dropbox.com/s/r4sikntahofml85/Log 2018-12-22 10%3B21%3B55 pm.llg?dl=0


https://www.dropbox.com/s/sei4r0aepxh0rrv/LINKECU FORUM TestMAP - 1.99904.pclr?dl=0


If anyone has any other ideas, or notices anything from the logs and the map, I'd be grateful for your suggestions.

Thanks again,  and Happy Holidays!

Link to comment
Share on other sites

So you're saying key on, engine off, the map sensor correctly reads atmospheric pressure, as it always did ?

And when you test with a Mity vac, it behaves as you'd expect both into vacuum and then positive pressure reading via PCLink ?


Not sure how anyone could actually install cams so badly, nevermind have the engine run with an actual 6psi positive gauge pressure in the intake at idle.


Can you compare a trigger scope of crank/cam trigger before/after to see if there are huge differences there ?


Can you confirm ignition timing is as expected ?

IDC seems very low, even for idle, what are mixtures like ?


Compression test ?

And why on initial cranking on log 1 does MAP reading hit the floor ? That is not normal, and could be more likely a wiring or faulty sensor or something.


Because the engine should never be able to achieve that, nevermind that it then shoots to over 100kpa as rpm rises a little, again not possible.

Link to comment
Share on other sites

Correct... Map sensor tests out as I would expect it to... Both in vacuum and with postive pressure when read via PCLink when tested with the Mityvac device.

I'm about to go test out the ignition timing on the car. Never done this before, so trying to read up on the procedure.

The first log has the base pressure set at 34psi. For all others, it was bumped up to 54 psi, which is where my tuner prefers it to be set.

The shop that performed the install actually race Subaru's professionally, and were 100% sure everything was installed to the book. With that said, I am attempting to check what I can of the car in my garage.

Unfortunately, I don't have a scope of the car from before with the old cams in place.

My tuner was able to remotely log in and determined that the ECU definitely was not dealing with trigger errors... 

Should changing camshafts require that one perform an ignition base timing test again on the engine?

Sorry, no compression test. I don't have a tester at home here, and the cam swap was literally just accomplished a couple of weeks ago. It has only been idled in order to break the cams in. Have not been able to drive the car on the road given what it is doing at the moment.

Link to comment
Share on other sites


Just checked the base timing, and it is spot on the money when locked to 10 degrees with the PCLink.

The other odd thing:

Not sure if the MityVac did something positive to the map sensor last night, but when I fired up the engine just now to check the ignition timing, I noticed that it is no longer thinking that it is in boost while at idle. It actually references from the vacuum section of the ECU map again.


Here are a couple of logs... should have been a single log, but i kept getting excited about things and kept disconnecting the ECU instead of saving the log.


https://www.dropbox.com/s/tvtwel2wx4n3tig/log 2018-12-24 - log 2.llg?dl=0

https://www.dropbox.com/s/1uf6m7nmo565hl5/Log 2018-12-24 4%3B28%3B39 pm.llg?dl=0

Link to comment
Share on other sites

Whether 34psi or 54psi base pressure...little odds.


Although typically base pressure would be around 45psi with no vac connected. I personally would not go lower than that, but each to their own. 


If crank trigger has not been touched, then no there should not be a need to confirm timing etc....but as you are having very strange readings/problems, a simple quick test makes sense.


I presume your first log is with you playing with the Mityvac ? If so, why in the middle are there two incidents where throttle appears to have opened ? Did you do that, as they seem very brief ?


and in your last log there, why is the map sensor stuck in the 140kpa range ?


Unless you have some wiring issues....or plumbing to the map sensor issues...replace the map sensor.



Link to comment
Share on other sites

52 minutes ago, Stevieturbo said:

Whether 34psi or 54psi base pressure...little odds.


Although typically base pressure would be around 45psi with no vac connected. I personally would not go lower than that, but each to their own. 


If crank trigger has not been touched, then no there should not be a need to confirm timing etc....but as you are having very strange readings/problems, a simple quick test makes sense.


I presume your first log is with you playing with the Mityvac ? If so, why in the middle are there two incidents where throttle appears to have opened ? Did you do that, as they seem very brief ?


and in your last log there, why is the map sensor stuck in the 140kpa range ?


Unless you have some wiring issues....or plumbing to the map sensor issues...replace the map sensor.



Thanks for your response Stevieturbo

I didn't post any logs of me testing with the MityVac. For that part, I simply wrote down what PSI I sent to to the map sensor, and also wrote down what I was seeing on PCLink in response to the pressure going in from the MityVac.

Here is the data from testing the map sensor with the MityVac:

Key On, 0psi on Mityvac:
MAP (psi): 14.1
MGP (psi): 0psi
~5Psi on Mityvac:
MAP (psi): 18.1
MBP (psi): 4.1
~6psi on Mityvac:
MAP (psi): 20.5
MGB (psi): 6.4
~10psi on Mityvac:
MAP (psi): 23.2
MGB (psi): 9.1
~15psi on Mityvac:
MAP (psi): 29.6
MGP (psi): 15.5
I tried to go to ~20psi, but the pump would not seem to easily support it, and I did not want to break the handle of the pump..


I typically run a base fuel pressure of 54psi on my setup. Yes, I know that ~43psi is the standard, but I get much better atomization with a little more pressure. Since I have the fuel system to support it, it works for me. The shop that reassembled the engine turned the fuel pressure down from 54psi to 34psi because they had no access to the ECU, and also noticed that the engine was being grossly overfuelled, but would not have been able to know that the reason why the car was running so rich after the cam swap was because the map sensor was telling the ECU that it was in boost.

In order to reduce the amount of fuel going to the engine (to run well enough to break in the cams), they had to dial fuel pressure down a bit. They told me about this when I picked the car up from them, and they were sure that everything from a mechanical perspective on their part had been done correctly. They did not want to get into the ECU to start probing things there since they did not tune the car. 

The first set of logs were from when my tuner connected remotely trying to see if there was anything obvious that could be ascertained. He noticed that the ECU was sampling fuelling values from the wrong part of the map, and we needed to figure out why that was. I may have given some throttle here and there to see how the engine reacted. On his instruction, I had a cursory look at the map sensor wiring and the like for anything odd, but did not find anything at the time. Tuner then suggested picking up a MityVac to test the map sensor to see if it is working correctly.

It was at a later point in the day that I ran testing with the MityVac, and everything looked to be in line with what it should have been. I reported this to the tuner. Next thing to check was the ignition timing to ensure that the ECU was running the timing we thought it was running. He also thought that  there should be no reason to check this if the crank trigger had not been touched, but with what we were seeing initially, we had to run through all options methodically to rule things out.

That is what I was going to check yesterday. I disconnected the Mityvac, trimmed a little bit of vacuum hose off the map sensor that I had used to attach the Mityvac, reconnected said vacuum hose to the intake manifold and then went to start the car for the base ignition test. Once started, I realized that the ECU was now sampling from what looked to be the correct area of the map again.

Through all of this though, the MAP and MGB always matched on PCLink when the engine was off and key on.

I may have had a slight kink in the vacuum line connection to the intake manifold, given the way everything is packaged, as well as the vacuum hose being a bit weathered (i.e. hard) so I will be re-plumbing the map sensor to the manifold with fresh hose. The kink may not have been bad enough to show up in readings when the engine was off, but with it on, was causing the map sensor to give off erroneous readings.



Link to comment
Share on other sites

Some of the logs you posted, record the ecu live, engine not turning and MAP changing at varying levels, both vac and pressure.

key on, engine off should be around 100kpa ( and this appears correct ), ie atmospheric. So are you saying you were not messing with the map sensor when these varying readings were happening ? If so...why where they happening ? it looks like they are being tested. Mityvac should easily be able to get to the 60psi or so their gauge goes to, although a test to 20psi gauge pressure should be fine.

map test.jpg

Link to comment
Share on other sites

Oh I see what you mean!! I completely forgot that I had the ECU internal logging on, and I did not realize that it was the internal data that I posted for you to see... My bad! Yes, what you are seeing in that area is me testing the system.

I could only get up to 20 psi because I purchased the plastic version of the Mityvac, and I did not want to snap the handle while trying to push over 20psi at the map sensor. The device can definitely go higher I suspect, but I'd rather not break it in trying to do so. If I sprung for the metal version, I think I could have easily pushed more air into the system. In hindsight, I think I might return this in exchange for the metal version later.

Yes, some of those where the MAP value is changing and the engine is not turning would be me testing the system with both positive and vacuum pressure.

And yes, I do recall hitting the throttle briefly while testing as I was trying to make sure that the PCLink was in fact recording what I was doing... by blipping the throttle, I could easily see the TPS graph move on the screen.

Sorry about that!

Link to comment
Share on other sites

Did you compression test and/or leakdown test the engine since rebuild? From your first log a couple things look wrong.

1) as you mention, its idling at 140kpa (ie 40kpa boost) - should be between 30-40kps on stock cams and maybe 70 or 80 on race cams. (your latest log looks about correct)

2) when cranking, its showing 30kpa (ie MGP of -70kpa) - should be only a couple points off atmostpheric. Plus it drops to 0 for a second immediately on crank (as mentioned above)

3) your MAP is jumping around like crazy at idle. (maybe 40kpa between peaks/trough)

4) all of your logs show IAT's of near or just below 0. is it really cold there or is your IAT calibrated wrong?


The fact it seems to have fixed itself, plus the above points means i'm leaning towards a stuck intake valve (maybe too low tolerances mixed with the cold?). in this scenario the boost you are seeing would actually be cylinder pressure being pushed back up into the intake. 

If it hadnt fixed itself, or i've read your post wrong, id be leaning towards your new cams being mis-installed. Seems too much of a coincidence that new cams went in and suddenly you are seeing behavior that aligns perfectly with cam alignment problems or wrong cam in the wrong spot problems. compression test or leakdown test will show if this is the problem

Link to comment
Share on other sites

Hi - Im sure no amount of bad cam timing or ignition timiming or stuck valves or any other mechanical issue is going to make an engine idle at 6psi positive pressure - No way - no how . Hook up a mechanical vacuum gauge to confirm . I think it will be a map sensor or electrical issue over mechanical .  

Link to comment
Share on other sites

Sorry for the lack of updates.. It wasn't a mechanical issue with the engine after all, although I could not say with 100% certainty what the issue was since it seemed to be resolved after re-installing the map sensor slightly differently compared to before.

Map sensor was not reading correctly, but I suspect it  was due to a kink in the vacuum hose to it. Following my testing with the Mityvac, I re-installed with new vacuum hose and relocated it so that the vacuum hose was not precariously/tightly angled on its way to the intake manifold as it seemed to be prior, and once I restarted he car, all appeared to be well in the world again.

I suspected also that the engine was not actually seeing 6psi sitting at idle because my OEM boost gauge is plumbed independently to the intake manifold, it it never registered positive boost. 

I now seem to have a fuel pump control-related issue, but I will start a new thread on that one.

Thanks to all of you who chimed in :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...