Jump to content
Sign in to follow this  
SteveX

Retarding injectors for a new cam

Recommended Posts

Hi guys, currently running a RV8, fitted with a h404 cam. I can’t find the specs on the cam but understand it has a large overlap. Car has been mapped and is making great power and running well, but it stinks on tickover (no cats). It’s running as lean as poss on tickover, so I can only assume fuel is coming out of the exhaust ports. It’s currently been upped to 340 from 330, but my question is, how much further is OK? I moved to 350 and no issues at idle it would seem, how far can I go? Just trying to minimise the rich fuel smell on tickover, but not sure of the negative effects of having the injectors so close to TDC. Thanks!

Share this post


Link to post
Share on other sites

If you are timing the injectors using 'end of injection' then you want to make sure that the injector stops firing as soon as the inlet cam has closed, there is no point in firing it on the back of a closed valve. This is not the problem thought I wouldn't have thought.

Please post your map and log for further assistance.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...