Jump to content
v8bloke

Traction control wiring

Recommended Posts

In the past I have paid for my Extreme ECU to be fitted and have been disappointed in the quality of the work so I would like to do this myself.

I am not very confident when it comes to wiring  so please excuse the basic questions.

Fitted KA SP08-NPN-25-100-100 hall effect sensors. do these have to be connected to sensor ground or just normal earth?  Pullup resistor set to OFF? Active edge rising or falling?

Using DI 1 for LF wheel speed and DI 2 for RR wheel speed. I'm OK with the calibration.

DI 3 is set to Traction disable switch. Pullup resistor ON? on level set to LOW? Rocker switch wired to normal ground.

Am I right in thinking that if I enable table 2 the Disable switch will switch between the two tables?

Looking forward to trying this out.

Thanks.

 

Share this post


Link to post
Share on other sites
4 minutes ago, v8bloke said:

Fitted KA SP08-NPN-25-100-100 hall effect sensors. do these have to be connected to sensor ground or just normal earth?  Pullup resistor set to OFF? Active edge rising or falling?

Use sensor ground, pullup on, active edge will likely be fine either way.

 

5 minutes ago, v8bloke said:

DI 3 is set to Traction disable switch. Pullup resistor ON? on level set to LOW? Rocker switch wired to normal ground.

Pull up on.  On level could be high or low depending on which position you want to be on and off.  Just watch the runtime once you have it wired and if it doesnt work how you want change to the opposite setting.

 

6 minutes ago, v8bloke said:

Am I right in thinking that if I enable table 2 the Disable switch will switch between the two tables?

The disable switch is there to completely disable traction control.  If you want two tables those can be switched by another DI, a virtual aux, or pretty much whatever other condition you want.

Share this post


Link to post
Share on other sites

Thanks,

I have it all wired up.

Front Wheel speed is DI1 Rear is DI2, Traction disable switch is DI3 and to switch between traction table 1 and 2 is DI4.

looking at the runtime data spinning the wheels DI1 and 2 show as being active. switching DI4 to earth shows the switch as active but DI3 The traction disable switch only shows to be briefly active then goes back to off is this correct?

I would have thought that DI3 would remain active until switched back?

Thanks for the help.

Share this post


Link to post
Share on other sites

Yes DI3 and DI4 switch to ground. In runtime values DI3 is set to Traction disable switch. When DI 3 is earthed it shows as active for about a second then turns off. I have tried another switch but still same. Both DI3 and DI4 are earthed at the same point.

have attached map.

 

Thank you.

NDMarch19 with TC.pclr

Share this post


Link to post
Share on other sites

Ok, you are on very old firmware.  It is original form the traction disable switch was designed to be from a momentary button like most cars have on the dash - one press for on another press for off.  In newer firmware this function was made more flexible to allow it to work with toggle switches like you have.

So update to the latest firmware, then in traction control settings you will have a new setting "traction disable switch", set it to toggle and you will be away.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...