Jump to content
MGV101

Random igniton cut on high throttle input

Recommended Posts

I seem to be getting a lot of random ignition cut lately. I thought it was due to MAP limit being triggered from over boosting which was initially true but as boost was begin dialed in I was still getting ignition cut under hard acceleration. All this was happening at the track and it was difficult being the driver and tuner at the same time so it was overlooked and I simply continued to dial the boost down thinking I was just touching the MAP limit.

Now that I have returned and have time to look at the logs in detail, I noted MAP was very much in check most of the time when the ignition cut occurred. Sadly, none of the Limit status was logged so I have no idea which limit was triggering the ignition cut but I do have Percentage ICut logged so I know for sure the sudden drop in power and loud pop coming from my exhaust was due to ignition cut.

Attached are maps and logs from the second day of the track event (after addressing most of the overboosting issue) to help identify the problem. The first map was uploaded to the ECU in the morning where the ECU statistics had also been reset. The first log were pulled around noon after a couple runs at the track (somehow it only recorded one session). The second map was upload to the ECU right after pulling the first log with some minor updates to the PID boost control as I still thought it was the MAP limit causing problems and the second log were of the track sessions logged after loading the second map, closed loop lambda had also been disabled as all the pops and bangs from the ignition cut seemed to have killed my wideband.

Looking at the logs you could see when ICut was being applied, MAP was nowhere near the 250kpa MAP limit or 235kpa after factoring in the 15kpa control range. Looking at the engine speed however, I've noted there were sometimes, a sudden spike in engine RPM when the ignition cut occurs. However, this only happens 1/4 of the time and seems to happen miliseconds after the ignition cut kicks in so I suppose it was the violent ignition cut itself throwing the RPM off rather than it being a cut due to RPM limit? Engine speed is being logged at 50hz, is it fast enough to catch all the rpm spikes that the ECU itself sees or could it be too slow?

Other than the RPM and MAP limit trigging the igniton cut, I was unable to identify any other settings on the map which could cause the cut. Could anyone offer some help? Thank you!

I would love to go on the street and test everything again now to diagnose the problem but sadly, due to the strict modification laws here in Hong Kong and the fact that its such a crowded city, there is no way I could drive my dedicated track car on the street without drawing attention and getting caught. Also, there are no race tracks in Hong Kong and the only option to hit the track is to travel up to mainland China which requires the application of a special one time permit (unless you are some one rich who can afford regular cross border license) so the opportunity of road testing the car at the track is really limited.

Day 2-1.pclr Day 2-2af.pclr JITL Race 1.llg

Below is the second log on google drive which I am unable to upload due to file restrictions:

https://drive.google.com/open?id=1Wnbves6DvJpBVGHoEAw0pVCqoVuJ9DGg

Share this post


Link to post
Share on other sites

To add a little backgroung information. This is a Gen 3 3SGTE engine on a MR2 managed by a Link G4+ Fury with the distributor replaced by a crank 36-1 crank sensor and a cam sensor with LS2 truck coils.

Share this post


Link to post
Share on other sites

There's not quite enough channels recorded to give a conclusive diagnosis, but my feeling is it is trigger errors causing the rev limit to activate.  This is because many of the limiter events are associated with a spike in the RPM trace.  (FYI, a good parameter to log is "Limits Flag Word")

The reason you dont see spikes every time is the logged RPM is averaged over one TDC event (90degs) so it will depend how bad the trigger error is as to whether it will result in a logged spike or not. 

I notice you have a hall sensor on a 36-1 wheel, what sensor have you used and what is the wheel/tooth design like?  Can you give us a picture or something?.  

Share this post


Link to post
Share on other sites

Tried to replicate the problem today by free revving the engine but seems like it only happens under load and given I cannot drive the car outside, I cannot replicate it.

For the trigger setup, it was an off the shelf kit specifically made for the MR2. The trigger wheel and the sensor were supplied by the same shop as a kit with a Cherry GS10701 sensor but specification of the trigger wheel did not exactly fall within the specs recommended by Cherry (http://switches-sensors.zf.com/us/wp-content/uploads/sites/7/2012/05/Datasheet_GS1005-GS1007_Letter_EN.pdf). The wheel itself is only a little over 3mm thick vs 6mm as recommended and tooth gap is approximately 5mm vs the recommended 10mm. However, when I looked at the trigger scope when installing the trigger setup for the first time, the signal looked clean (and it still does now) so I never thought much about it as everything worked. My trigger setup had actually been working trouble free for over a year. Could the sensor be failing?

Here is a link to the kit I use but I've skipped the 1zz coil part using just the crank and cam sensor from the kir. http://racerxfabrication.com/mr2-celica/ignition/1zz-coil-on-plug

If I were to change the hall sensor, is there any recommended alternative that I can use? Preferably in the same form factor so I could use the existing mounting. Also for the trigger scope, should I try running it at a higher RPM to see whether there is any degradation of signal when the frequency increase?

 

20190413_115916.jpg

20190413_115928.jpg

20190413_122304.jpg

Share this post


Link to post
Share on other sites

Those Cherry/ZF sensors need quite a strong pull up resistor to work properly.  The wheel design looks ok to me.  The first thing I would try is adding the correct value pull-up resistor as recomended in the datasheet.  The internal pull-up in the ECU is 4.7Kohm to 5V.  Cherry recommend 1K when powered by 5V so it is quite different.

2m4rj95.png

 

Share this post


Link to post
Share on other sites

Thank you Adam. I am actually using the 8V power source from the Fury ECU so the recommended resistor would be approximately 1.8K, its slightly closer but still pretty very far from 4.7K.

This may explain why I never had the trigger error before though as I have only switched to a fury unit at the end of 2018. I was using a plug-in unit before which did not have a 8V output so I was using 12V instead which would give a closer recommended value of 2.4K.

So to correct this, I'll have to turn off the pull up resistor on the ECU and wire in my own? 

So to correct this, I'll have to turn off the pull up resistor on the ECU and wire in my own? 

 

Edit: Oh, we actually discussed the pull up resistor before on 12V a long time ago and I almost forgot about it. 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...