Jump to content

Unable to connect to ECU after flashing firmware to

Josh Colombo

Recommended Posts

I updated the firmware to the latest version from version 4.4.3.  It succeeded successfully, but once it completed the update I’m now not able to connect to the ECU any more.  I tried uninstalling and reinstalling PC Link and the USB drivers.  The USB drivers detected the ECU on initially being connected but I still can’t connect to the ECU, neither with PC Link or the firmware updater.   I even tried a different laptop, and got the same response, 'Unable to connect to ECU'.

When I get a little more time, I will check the power going to the ECU, but I believe it's fine because the tach sweep is still completed when I turn the ignition to the 'ON' position (This is controlled via the ECU), so I would believe the ECU is still working.  Other notes is that I have the Display Link wiring hooked up to the ECU, but the Display Link is not plugged into it.  Also this is a G3 Link Plus ECU that has been running G4 firmware without any issues in the past.

Any ideas or help would be greatly appreciated?


Link to comment
Share on other sites

Well after trying a bunch of different combinations of things and talking with one of the US Link Dealers we got it figured out.  It turned out to be an issue with the upgrades to the CAN system and the fact that I had the DisplayLink cable plugged into the ECU, even though it wasn't connected to the DisplayLink.

PCLink version is last version before the CAN system got a major overhaul.  This version of PCLink & firmware worked with my ECU after downgrading the firmware.  Once I went any higher, I couldn't connect.  We finally determined the DisplayLink cable being plugged in was the cause.  Once I removed the cable from the ECU, I could connect to the ECU with the latest version of PCLink,

The Link Dealer indicated that there is a hardware upgrade that can be made to my G3 ECU as well as other G4 ECU's that have similar issues that will allow the ECU to communicate with the DisplayLink and PCLink at the same time.  So I just sent the ECU back to Link for the upgrades.

Hopefully this well help someone else in the future.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...