Jump to content

Lambda not giving any readings


Recommended Posts

I recently purchased a link g4x ecu for my s15, along with can gauge and can lambda. after connecting can gauge to can 1 and can lambda to can 2, i can not get the lambda to give me any afr reading. it stays at zero on pclink as well as on the can gauge. i know the can gauge works because it gives an rpm reading, but nothing for afr.

I went through the process and made sure everything is on the correct mode, correct hz, correct channels, and i can always get the gauge to work but not the lamda.

The lambda target starts at around 12 when car is off, and slowly works its way up to 14.7 and then stays at 14.7. but that is the only lambda number that seems to change. the actual “lambda 1 afr” on pclink never changes from zero.

Was wondering if you guys know of anything i may be missing? i have checked pinouts and made sure wiring is correct. ive tried connecting can gauge and can lambda to can 1 using the splitter, and ive also tried using them both on their own can.


Link to comment
Share on other sites

On 1/23/2024 at 11:01 AM, Vaughan said:

Have you set Analog Inputs -> Lambda 1 -> Lambda Sensor Control to Link CAN?

Attach a copy of your tune and a pclink log of the engine running please if that isn't your issue.

I just did what you mentioned, and now they are both working properly. i appreciate the response very much.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...