Jump to content

Firmware update question

William B. Cushman

Recommended Posts

Probably a really stupid question . . . but I just got my Extreme installed, powered up, and talking to the latest version of PCLink (downloaded two or three days ago). The PCLink download included a new firmware version, so I thought I would start by installing it. I tried clicking on the PCLink button to do this, and it responded with a window saying that the ECU had to be disconnected first. How can that be? It needs to be in the car and connected to have power . . . I thought. So I shut everything down to see if I could find some detailed directions here, and so far I haven't. Can someone point me in the right direction? Do I really have to remove the unit and arrange power somehow? Thanks! Bill

Link to comment
Share on other sites

Hi Bill.

That is the correct responce from the unit, as it want's to disconnect the PCLink, and connect the ECU updater program (kind of a separate entity).  You can start with being not connected and hit the Upgrade Firmware button too... This way the updater will connect right from the get go.

Just tell it your OK with it diconnecting and it will automatically disconnect PCLink, and reconnect the updater to do the update.  The window you will be follwing here for the on screen instructions through the upgrade is the black DOS like looking window.

Please don't forget to read the update changes that pop up first... This is very important!


Link to comment
Share on other sites

Thanks again Jurgen, I definitely misunderstood what was to be disconnected there . . . So I disconnected PCLink from the Extreme and tried the firmware update again, but this time the program popped up a window with a 'Cannot start updater' error. I found the updater in the directory and tried starting it directly, but then I got an error message saying it was 'Not a valid 32 bit program,' which is probably why PCLink couldn't start it. Just to be sure, I've downloaded the program three times now, all with the same result. This whole thing is complicated (naturally!) by the fact that I'm using a MacBook Pro with Windows 2K loaded in VMware. The PCLink software does seem to operate well, however. It is clearly communicating with the Extreme, and could, for example, return the firmware version in the help menu (4.6.0). Any ideas would be greatly appreciated! I'm stumped. I've been trying to get past this all day. Bill

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...