Jump to content

Can-lambda big problems

Typ17 16vg60

Recommended Posts

Hello everyone, I have the following problem.  After my link can-lambda finally arrived after half a year of delivery, I wanted to set it on Wednesday.  So far so good, have a g4 + extreme with the latest firmware.  So DI9 and DI10 cables pulled and twisted.  Plus secured by a relay and minus by battery.  Following problem.  On Wednesday I installed the tool via can2 after the help file.  The first 5x it found nothing despite the correct settings.  Suddenly out of nowhere it was to be found and could select it as lambda 1. But then I found that when I started the engine I had a lambda error average and that no control functioned.  On Thursday we continued on the car, but suddenly the module can no longer be found in the can setup and gets warm, and the probe always heats up.  Vehicle is a golf1 16T. Only the lambda module is connected to the canbus.  Tried all things that have already been suggested here in the forum in other topics.  Another rate when connecting id950, power and ground directly via an external good battery can low always has 2v and can high 3v, with and without resistance, connected and disconnected probe when searching and and and and.  Everything else works perfectly except for the can module.  Could it be broken?  After half a year of delivery, I don't want to wait that long again and I'm really disappointed. Maybe enyone have a idea. Greetings BennyIMG_20200709_212009.thumb.jpg.f52ff58ca132ef3362f873c835734a17.jpgIMG_20200709_212009.thumb.jpg.f52ff58ca132ef3362f873c835734a17.jpgIMG_20200709_212009.thumb.jpg.f52ff58ca132ef3362f873c835734a17.jpg

Link to comment
Share on other sites

Your screen shots suggest you have a CAN bus wiring problem.  With the ignition off, can you measure the resistance across the CANH/L wires.  Do this with everything still plugged in by "back probing" at one of the connectors by pushing a couple of pins or paperclips or similar down through the wire seals into the terminals.

You should have about 60ohms if both ends are connected and the terminating resistor is there.

Link to comment
Share on other sites

Hello adamw and thanks for the very fast answer :)


I messured how you want, I have everytime a resistance from 119ohm (my resistance) between my can high and can low. 

Equal I messured on the connector to the Modul, or on my can high and can low cable from the ecu (key ignition off) 


Link to comment
Share on other sites

So that suggest either you dont have the terminating resistor fitted or one end is disconnected.

Did you fit a 120ohm terminating resistor at the CAN lambda plug?  That doesnt usually stop them from working but it is proper practice to have a resistor at the end.

Link to comment
Share on other sites

Yes I have on the end the terminating resistor (119ohm)

Thats the value what I messured on the ecu plug, module plug

Without the terminating resistor I messured 40K ohm between Can H/L

In the ecu software I set the Di9 DI10 off

When I go to the Can menu and set can1 and can2 to off and apply then ignition off and on, all can Infos are green (ok make sense) 

When I set can2 to the can lambda the errors are there

vom golf test.pclr

Link to comment
Share on other sites

The ECU has a 120ohm resistor inside.  You say you have a 120ohm resistor at the CAN lambda end.  So total combined resistance when you measure across the CAN wires should be about 60ohm, not 119ohm that you say you measure.  

So there is a disconnection somewhere.  One of the CAN wires is not making proper contact at one end.  

Check that the pins in the DTM connector are pushed all the way home, I have seen those push back out before if they are not inserted into the housing all the way until the barb locks them.

Link to comment
Share on other sites

Ok from beginning 

Only the loose single can from ecu have 478k ohm messured 

Only the loose module have 43ohm messured 

Only connect the lambda module with ecu connect have 39ohm messured on the module

When i put the loose 120ohm terminate resistance to the module, I messured everywhere 119ohm

That's I'm wondering about

All messured ignition off



Link to comment
Share on other sites

To now,

I try another wiring, not direct from the ecu to the Modul where sitting my external terminate resistor too

Now I try a paralell can H/L wiring line with two 120ohm terminate resistor, one on both ends 

Now I messured 60ohm between can h/L everywhere 

But with no another result, it's stay the same problem, same errors and no finding in the can settings 

Im wondering about the can settings was finding ok, after maybe 5 finding test on Wednesday (but with lambda average error) 

Then next day by connect the laptop to ecu coming the canbus error and I can't finding the module in can settings

I messured all time my external terminate resistor, without any resistor I messured 39kilo ohm, anything happens to my can2

A another thing I have test, DI9 and DI10 set to a gp input against negative ground, that was ok and work fine (I see it on the F12 ecu info) 

I now the DI are not the can, but for any info maybe it helps for the very curious problem. 

When i connect the module for searching in the can settings (without result) , the O2 sensor heading up and stay hot, the Modul is warm too, but not hot



Link to comment
Share on other sites

Sorry, after giving it more thought this morning, measuring resistance across the CAN wires with ignition off is no use as the termination resistor inside the ECU will be disconnected when power is off.  You cant really check with it powered up as the CAN data will upset the resistance measurement.  The the measurement results that you have got earlier are normal.  


3 hours ago, Typ17 16vg60 said:

When i connect the module for searching in the can settings (without result) , the O2 sensor heading up and stay hot, the Modul is warm too, but not hot

Yes, that is normal, if the lambda device doesnt receive a valid CAN measage from the ecu within 15 seconds of power up then it will power up the heater.  So this observation means your Lambda device has got power but no CAN message.  

The CAN errors in the Runtimes screen means the ECU is sending out data but not getting any acknowledge message.  

Do you have or know anyone with an oscilloscope you could borrow to put on the CAN wires?

Or are you able to temporarily move your CAN wires from the CAN 2 pins to the CAN 1 pins?  You can possibly just hold them on the pins by hand as a test.

Link to comment
Share on other sites

Yes, I check it and the pinout is correct, white wire on (canH) pin4 and the green wire is on pin3 (canL) 

I try to set different, 500k and the other option, same result. No finding. My dealer will change the Modul for warranty.. 

I'm confused about the incorrect working on Wednesday with the lambda average error and the next day it don't find it anymore. So it must happens anything to the Modul 

I test different wiring connections on the bus wire options, crimping, screwing.. All the same

Can1 can2.... 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...