Jump to content

Misfires with R8 coils


Recommended Posts


New engine reusing all ECU hardware - except coils - from trouble-free running previous engine, now misfires under load. Getting trigger #1 error exactly when it misfires. Trigger 1 is Bosch VR sensor. Trigger 2 is Hall sensor used for sync. Base timing checked and rechecked OK.

Coils are black top NGK U5015, same as R8 coils. Dwell set at 2ms.

Plugs are NGK BPR7ES with 0.7mm gap.

The only ways to get the engine not to misfire so far was either to run large spark plug gap like 1mm or massive amount of advance, but as soon as trying to boost it still misfires. Also getting misfires at high rpm under vacuum.

How do I tell if the coils are possibly causing electrical noise to the wiring of the trigger sensors?

Previous coils were Delco D514a running 4ms of dwell and worked perfectly with the previous engine but were replaced for packaging reason. Been resisting trying to run the new R8 coils with 4ms of dwell as they apparently would fry.

Still not clear to me if the trigger error is caused by the misfire or the opposite, as the engine revs absolutely fine on a standstill.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...