Jump to content

CAN-Lambda error 53 controller not found


Recommended Posts

I recently rewired my sensors, and am now having difficulty getting CAN Lambda working again. I added an ignition-switched relay for the CAN Lambda, as well as the 22uF capacitor, but strangely now when the engine is running I am seeing the Lambda status toggle between diagnostics and calibration, before reporting error 53 controller not found!. It then repeats the cycle with status changing from initializing back to diagnostics. I'm not sure if I damaged the CAN Lambda or O2 sensor somehow during the process, but I've checked all the basics (power, ground, and the CAN setup->CAN Devices in PC-Link appears to find the device) and have not found any obvious issues. Any advice or help would be appreciated. Log file attached.

Thanks, Mike

lambda issues.llg

Link to comment
Share on other sites

So has it previously worked ok before your re-wiring?  Did you only change the wiring on the 4 pin connector side of the controller or did you mess with the sensor side of the controller wiring also?

Can you attach the tune also.

Link to comment
Share on other sites

Hi Adam,

Thanks for response. Yes, it previously worked OK. I changed the entire harness from the Link board-level connector to the CAN-Lambda Deutsch connector. I did not mess with the O2 sensor side at all, other than unplugging the connector temporarily.

What I can't determine is did I mess up something with the rewiring, or did I compromise the hardware somehow. I'm not sure how to further debug. Do you have any suggestions?

I believe I've attached the current tune file.


Link to comment
Share on other sites

Ok, its really odd to see that error 54, but it appears to be communicating correctly so we can assuming the CAN side is ok.   It is like it isnt powering up fully or something.

So as a test I would pull your power/ground wires out of the DTM plug and temporarily run to new wires direct to the battery, so that all the existing power supply is bypassed.  If it then boots up and works with no errors then you can concentrate on it being a power supply issue.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...