Jump to content

Unable to connect to storm x ecu


Recommended Posts


Trying to connect to my link storm x ecu however, I have been unable to connect to the ecu. I have a yellow hazard triangle in the device manager and I have tried to automatically update the drives from the device manager but it fails to update drivers. I have manually gone into the link drivers folder and it still fails to update the drivers. 

I have tried manually setting the ecu connection with the baud rate and connection port as detailed on other posts but still no luck. 

The ecu was mapped by a company but due to a fuel pump dying I am going to make some adjustments to get it running better with the new pump however, I just can't connect. 

Any help would be greatly appreciated. 

Thanks kindly


Link to comment
Share on other sites

Ok, thats an odd one that I havent struck before.  Does your windows account have administrator privileges on that laptop?

Can you try going to the C:\Link G4X\PCLink G4X\Link USB Drivers folder on your PC and right click on the "linkUSBDrivers_X**.exe" and choose run as administrator.  Use the X64.exe if you if you have 64bit windows or use X86.exe for 32bit windows. 


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...