Jump to content

Fuel Pump Speed Control Table


Zefy
 Share

Recommended Posts

i feel like i'm missing something here. Planning to go to a brushless fuel pump as they have built in speed control which I will use with my big injector (ID1700's) on my subaru. I have a few options for speed control and it seems the most appealing option is the open loop control.

 

Playing with the software though, it appears that the FP Speed Table isn't there. Table options appear for the other control strategies but not for open loop. What am i missing? Using G4+ PCLink on my vipec i44

 

PCLink version 5.6.5.3338

version 3372 

Tried to upload an image of the info screen but the upload option isn't working. I can email whoever needs to see it. 

Link to comment
Share on other sites

  • 2 weeks later...

I don't have access to the car right now to update the firmware but i wanted to make sure i would be able use an open loop control with my ecu. I don't know what the current firmware is and whether my ecu can support it (being rather old).

the help file shows firmware 5.4.3 not supporting it. What is the current firmware for my vipec i44? This help file was from Ver: 5.6.8.3669 software which is the current option for link g4+ ecus. 

image.png.3ae142005941a56b7bcb92ac3688c703.png

 

Link to comment
Share on other sites

  • 6 months later...

Been having a ton of problems with these brushless pumps. Have tried 2 different brands and both had the same results. I attached a screen shot of the datalog. I updated to the most current firmware.

Basically the problem being experienced is a sudden drop in fuel pressure. this occurs every 5-10seconds. Swapping to the new pump (fuelabs brushless in tank) yielded similar but different results. When the pump experiences no signal it defaults to 100%. So my surging now went to 100% instead of 0%. Still very unusable. 

I was running FP speed off of Aux 6 on my vipec i44. I swapped it (in the ecu header) to aux 2. The problem was entirely fixed. Something is wrong with my aux 6 where it won't run a pwm properly. I didn't swap any of the wiring so i know it's not a bad connection. the left side of the datalog is with it using aux 6 where as after the datalog restart is running aux 2.

I can provide the datalogs and ecu cal file if you like but something is wrong with that aux channel. was running 100-300hz (i was varying it trying to diagnose). Not sure if it's something wrong with my ecu in particular or if it's something to do with these slower aux channels on the i44.

Another problem is when polarity is set to high (so it reads 0-100% pump speed as 0 is off and 100 is on instead of the other way around) the datalogger always shows 85%. Not sure why this is but i currently have no way to monitor pump speed beyond looking at the map trace live. aux 6 was showing 55% i think? 

275608897_974142666566941_4381131780151942503_n.jpg

Link to comment
Share on other sites

Log 2022-02-27 10;29;47 am idling blip.llg - this log at idle is using the DW brushless pump, running aux 6.

 

Unfortunately the main log where that screenshot is grabbed from is too large to upload here. it's just the ecu download. however it does show the DW pump installed, me bypassing the surge tank and running the lift pump instead, and then the fuelabs brushless install and rewiring to aux 2. 

I uploaded it to my google drive. hopefully you can see this: https://drive.google.com/file/d/11bf2vzC64m8iX-xU9RtXcmUVrrKoeehL/view?usp=sharing

up to 17:51 - DW brushless pump running aux 6

17:51 to 25:31 - running off lift pump (AEM 340 running 100%, fp speed controller not used)

25:31 to 25:45 - fuelabs brushless pump running aux 6

25:45 to end - fuelabs brushless pump running aux 2 - note that the reg is still set very low to deal with the lift pump running 100%. car is nowhere near tuned.

also note at 17:40 the fp speed datalogging stopped working. really not sure what happened here.

The two maps should be these. Newest one is the current map. Note the fp speed and the rest of the car isn't tuned really on either as i was diagnosing this problem. FP speed control is reversed on the  "fuel pump diag" map. 100% in PCLink is 0% pump speed, 0% in PCLink is 100% pump speed. I flipped the polarity to correct this when i did the fuelabs pump. This is the pump i am currently using. https://www.fuelab.com/25314-fuelab-universal-in-tank-brushless-kit/p408

2.5RS-2022-03-25 fuelab fuel pump.pclr 2.5RS-2022-03-03 fuel pump diag.pclr

Link to comment
Share on other sites

Update. Turns out the datalogging channel always reading the same thing is not the problem. 

Even though the table for idc% and fp speed can be whatever, it is only using the first cell. Immensely annoying as I was messing around with it all day and it was basically stuck at 5% pump speed. 

Link to comment
Share on other sites

Spot on Adam! Thank you. It works correctly now. :) 

I totally thought i had up to date firmware (did it a few months ago) but i was using an old version of the software. :(

It was weird because the table did interpolate properly with the DW pump running aux 6.

Would this also fix the problems i was experiencing on AUX 6 with the signal cutting out every few seconds? I will likely not change it back but should i need that output for a high frequency thing then i might...? 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...