Jump to content

LinkPlus G1 not running LS1 coilpacks

Chris MacWhirter

Recommended Posts

Hi again, its me and my dreaded project again; as per an old thread that probably belongs in the new G1 section, I have a holden 304ci v8 with a set of 8 later model LS1 coilpacks all fitted. Now, I had a problem of it sparking once on key-on, and that was it (Simon explained the ECU wasn't as quick to initialise as the instant-on coilpacks, issue solved) but now I cannot get any spark. After a bit of stuffing around and a lot of help from Ashley I've dumped the custom reluctor sensor arrangement and have gone for a Hall Effect system (crank & cam), and in conjunction with a new sub-board, seems to be getting the right signals to the ECU perfectly :) Sub-board lights flash correctly, et cetera. I checked the coilpacks on a separate homebrew wireup, they work nicely, but sadly the Link doesnt seem to fire them. I think I'm wrong, but it appears that when it charges the coilpacks then goes low to fire, it seems as if it isnt actually going low. Or alternatively it is staying low and won't go high, either way it seems a bit of a nuisance. I have had the cover off the Link to watch the sub-board lights, it has been adequately protected from any foreign matter, and I havent let the smoke out of anything onboard, so if anyone else or you guys at Link have any suggestions, it would make this idiots day! On a side note I did isolate the Links ignitor channels and attached one to a coil in the proscribed manner, but still no love. I have a cantakerous scope here too, if there is anything I should be measuring, if you want me to. Cheers, sorry to be a pain!

Link to comment
Share on other sites

Hi Chris

The LS1 coils have an inbuilt igniter so do not require any igniters between the coils and the ECU.

The lack on an RPM signal on PC link could be down to a missing sync pluse. Often this is down to dirty contact on the sub-board output pins. Also when no sync is getting through there will be no ignition pulses.

Suggest giving the pins and sockets a good clean with contact cleaner.


Link to comment
Share on other sites

  • 1 year later...

Ive a question or two about the LS# coils, Ive read on an AEM (gasp!) board that the later LS2 coils are 12v+ triggered not -ve triggered, is there any susbstance to this or can I go ahead and wire up the coils I have as per the link LS1 coil pinout picture? Heres the quote: "the truck coils will work...as long as they're the ls1-style.... The LS2 coils are different from the ls1's. Ls1's need a ground to trigger whereas the ls2's need voltage. The truck coils are supposed to provide a little hotter spark than the vette/f-body coils anyhow" and link: http://forum.aempower.com/forum/index.php?topic=21558.msg119628 Here are the coil part numbers: AC DELCO # D514A STANDARD # UF414 GM # 12573190 Cheers

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...