Jump to content

Intermittent fuel pump cutout

Nate Anderson

Recommended Posts

hey all...

so I've had this issue with my vehicle for some time now. I've exchanged emails with Simon over it.

I have an '85 VW Vanagon with a '06 Subaru EZ30r  and the Link G4 Extreme.

had a few towing bills and my tuner check the FP wireing, a new FP new FP relay, new ignition switch. old ignition was tested good as well as the FP relay and voltage for the related wires.

had it at my ECU tuners for 3 weeks while they checked circuts and found nothing wrong and it would not stall for them. they didn't bill me but still it's my daily driver so not exactly convenient.

I finally took it back as it wouldn't stall so, difficult to diagnose. hadn't stalled for me since then till last thursday. well, it didn't really stall, just wouldn't prime the FP or anything. no start. had it towed and of course, started up and would not stall again.

tonight I was about to go to the grocery and I think I may have eased out the clutch a tiny bit faster than I I pressed on the throttle and killed it. after this the FP would not prime again for several minuets...five or ten but you know it feels like forever.

unfortunately, I'm the end user and chief dumb guy here so I can't offer much technical knowledge. I'm a bit spooked to hook it up to my laptop as I don't want to screw up anything.

PCLink recently asked for an update on my desk top but when I hooked up my laptop to the internet, that install of PCLink didn't ask for the same update. just checked now and both versions are I don't believe the laptop has had any update so the original mapping my tuner did was most likely with this version. I can't think of any time it would have updated on my laptop  as I don't use it for anything but  this. I don't know if the ECU firmware is a separate thing from the PCLink software update

I used to think it was stalling at deceleration, but that wasn't the case at either of these last times.

also unfortunately, I have the link display, but there might be an issue with the baud rate and it will not get a signal from the ECU and I haven't had time to see if or how this can be fixed. I don't even have a standard tach hooked up.

I hate to take this thing out on the freeways cause there's no good place to pull over. but it doesn't seem to happen ever at freeway speeds. I do feel like at idle it's turning really low r's and could be just easy to kill. but to me it should just start up again whenever I turn the key...I mean why in the world would it not ?! 

just this night when I killed it I also pulled the battery cable a few times to see if that helped anything as Simon had suggested that. nothing happened. and as I just mentioned, I can't see why it should not fire up again after it was killed from dropping the clutch with no throttle. makes no sense whatsoever to me.

all I can think of now is at that last update notice there was mention of a change in fuel overrun cutout and that if my ECU firmware is indeed not current than maybe there is a fix  of some kind related to it in the update.

Link to comment
Share on other sites

It could be a firmware issue but not a known one so if you have a later firmware available it would be worth trying.

Also if you have a free Aux out it could be worth moving the FP to another Aux output. This will eliminate the option of a internal track problem or driver failure.

As a back up you could also have a switch to manually supply a ground to the fuel pump relay so if it stops you can flick the switch and pump should then run.

Link to comment
Share on other sites

  • 2 weeks later...

Hi Simon,

thanks for the replies.  well, we had a non start issue after filling up at a gas station.

my mechanic came down and we looked at it for a couple hours. tried jumping the fuel pump relay, and jumping the fuel pump to 12v, but it would not fire even with the fuel pump running. there was fuel pressure for sure as there is a gauge at the regulator.

we began to unwrap wires and decided the harness that connects the link to the vanagon and fuel pump was not wired properly. so I had it towed to my ECU tuners  for further work.

I told them (R&H Garage www.r-hgarage.com ) to tear into this harness and see what's the problem and re-do the whole thing if needed.

they found a lot of strange connections, 2 relays with only 3 wires on them power to the link was relayd through the fuel pump relay, some low voltage problems and shorting wires.

they had my laptop with the Link install instructions PDF and made me a new harness to power the link. the whole thing looks much better. nicely made with solder and shrink tube. looks great and should cured of the intermittent stalls now.

however, we still have a problem. I gave him the link display too. if you remember we I wrote you about this when I tried to connect it a few months ago. it powers on, but we got no signal from the ECU. Hunter did a bit of looking on the web to see if he could learn anything...he tried connecting it directly to the link and no signal either. I believe he also tried connecting to to other Link ECU's he had at the shop and got no signal to display.

I'm not sure what to do here. it cost me $800 plus $50 each for 4 extra cords which I bought several months ago. I'm a bit concerned about weather it will ever work or not and either returning it for exchange or refund...weather the unit is faulty or not.  I just don't know if it's a problem with the unit or what.  I did give Hunter the link display in it's box with instructions. but I had already made the connection to power and ground as directed. I had made a mount for it with a sort of heavy duty velcro material. 

I hope this can be resolved somehow and we can get this display to work, or a replacement unit if for some reason this one is faulty. if not are there any alternative to the link display aside from a series of gauges ? I would very much like to see codes and have the dataloging feature.

thanks again for all your help.


Link to comment
Share on other sites

Sorting the display should be easier than the stopping issues.

First guess is the Baud rat on the ECU will need to be set to 57600.

This is lower than the default setting. Also make sue in the dash it is set to Link G4.

If it is a ECU with Serial number higher than 10000 CAN is also an option. In this case the CAN will need to be configured through PC link and the dash will need to be set as Link uCAN

Link to comment
Share on other sites

Yes you mentioned the baud rate before and I did tell my guys about that.

they found no specific info on the baud rate or how to set it...can you detail the process of adjusting the baud rate ?

I didn't see any options in the PC Link software myself. I also haven't seen it detailed in the instruction manual for the ECU. I will check through it again.

I will check the serial # on my ECU this weekend and also look into the baud rate if you can describe the process for me.

I also did try setting the display to uCAN  when I wired it up. I still got no signal.  I was sure I set it to G4 first, then I tried uCAN as well.

thanks !


Link to comment
Share on other sites

Ok Simon I found it. thanks.

tried to make the change but couldn't establish connection with the PC. I tried auto connect and manual and just got 'searching'  and 'offline' flashing back and forth.

I know it can connect as R&H have done it a few times with this same laptop. I guess I'll stop by their shop and have them show me the trick. I did have the manual pdf open and was reading the connection process...I think I did it all in the right order. I don't know...

in my control panel on my laptop the ECU was listed as being connected to COM3 so when I tried manual connection, I set it to that.  either way, auto or manual didn't seem to work. key was in the ON position...engine not running but  where the fuel pump primes for a moment.

anyway...heh, seems like we are close !

thanks again for your time.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...