Jump to content

AEM X AFR - Can't get CAN to work...


Recommended Posts

I've been through the Evans videos and Link help about this and followed it but I can't get any output to the G4X. Analog 0-5v works fine if I set it up that way.

I have my own connectors and believe my wiring is correct?

I've tried CAN1 and 2. Also tried moving the power off the CAN2 connection in case it was that but still no joy. 

Also tried with and without the 120ohm resistor.

G4X R32 GTR-REV20-New AFR.pclx



Link to comment
Share on other sites

In your tune you attached you have the CAN 1 set to "transmit user stream 1".  It should be set to "Recieve User Stream 1".  In the stream in Frame 1 you have the ID position as 1, and it should be set to "None".  Alternatively - just delete the frame, and then select "load stream" at the top, and select AEM X-series UEGO.  This is all per the instructions in the link help menu.

Link to comment
Share on other sites

Can't believe I messed up the Mode selection. I blame lack of sleep! The rest was correct. I was messing about with the streams before so the actual cal file I'm using has that right. Glad it was simple.

Thanks, all working now. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...