Jump to content

PCLink in 5.2.2 firmware can't connect to ECU


Recommended Posts

ECU: G4+ Xtreme

After I downloaded the latest PCLink and fm package and I can't connect to the ECU. The software is frozen for a long time until it gives the "cannot connect to ECU"-message.

The ECU was running the previous firmware at this point.

Starting up the previous PCLink and trying to connect now gave the same issue as with the new PCLink. I though that maybe the USB drivers got screwed up. So I uninstalled both PCLink's and the driver (and deleted PCLink folders). Then reinstalled the latest version but still got the same issue.

Did this back and fourth a couple of times. At the end I left the car for a day and then when I got back I started with trying to connect using the previous version again. It worked. But then I tried the new version PClink once again and got the same issue that it can't connect/find the ECU (of course double checked the connection settings).

Now the weirdest thing was when I once again started the previous version and tried to connect - then I got a message saying that the operation required a newer version of PCLink! So it almost seems like starting up the new PCLink and trying to connect it somehow alters the ECU code!?

At this point I thought it might be a mismatch of firmware so I ran the firmware updater in the new PClink and upgraded to 5.2.2. That worked fine. Tried to connect with the latest PClink afterwards but....still got the can't connect issue.

Link to comment
Share on other sites


I've tested both Auto speed option's as well as selecting the slowest baud rate. 

The USB device shows up correctly in the device manager. I've also tested selecting the specific USB port assigned instead of the auto option.

Something must be off with the new PClink causing this. Also, the status message "searching for ECU" that can be seen at the bottom of PCLink doesn't show in the latest PCLink when it tries to connect.


Link to comment
Share on other sites

Hi Gustaf,

Have you tried using MANUAL connection and not AUTO CONNECT


SELECT CONNECTION PORT  as manual , drop down select your physical COM PORT

BAUD RATE select a slower speed as a test connection of say 38 400 or 57600, save this to the file and try connect.



Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...